Can't build Qt 5.6.1-1 on Linux...

  • Hi all,

    I've built older versions of Qt numerous times, but Qt 5.6 is giving me some grief. (Quick aside : I'm working with Qt support on this as well, but figured posting here might also help.)

    Initially, I was running ./configure with a bunch of command line options, but decided to keep it simple and just use "./configure" until I can get at least THAT much building.

    When I run ./configure, I don't see any errors, and am presented with the usual list of things that are enabled and not enabled along with the message telling me to run "make" to complete the build. However, when I run "make", I see this line repeated infinitely :

    /home/build/Qt/5.6/l64Src/qtbase/bin/qmake -o Makefile

    On my first attempt, I let that run over night, and in the morning it was still going. So, I'm pretty sure that it is an infinite loop. I also spent a few minutes last night attempting to debug the issue last night. I found that the file is getting processed correctly, but something in the Makefile that is generated by "./configure" is causing it to loop and run qmake again.

    My initial support request with Qt support suggested there might be a time/date issue, so I ran the commands they suggested and tried again, but the results were the same.

    I've also tried this on two different machines. One is a Mint 15 system with g++ 4.8.4, and the other is an Ubuntu 12.04 LTS system with g++ 4.6.

    Has anyone run in to this? And does anyone have a solution?

    Thanks in advance!

  • Lifetime Qt Champion


    One thing I'd do first is to do out of source builds. That way if something goes wrong, you can just nuke the folder and start again clean. I'd also check the file system just in case.

Log in to reply

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.