QML Debugger / dropped network



  • I'm experiencing very long waits to debug now using Qt Creator.
    v4.1.0
    It's an online web install
    Based on Qt 5.7.0 (MSVC2013, 32 bit)

    It now takes a long time to load and I've seen it tries and times out 10x before giving up presumably.
    While I'm doing QML form development this is making small frequent builds quite painful to wait over 30s each execution... has anyone else experienced this?

    sModule loaded: C:\WINDOWS\SYSTEM32\DCIMAN32.dll
    
    sQML Debugger: No application output received in time, trying to connect ...
    sQML Debugger: Resolving host
    sQML Debugger: Establishing network connection ...
    
    sQML Debugger: Network connection dropped
    
    sQML Debugger: Resolving host
    sQML Debugger: Establishing network connection ...
    
    sQML Debugger: Network connection dropped
    
    sQML Debugger: Resolving host
    sQML Debugger: Establishing network connection ...
    
    sQML Debugger: Network connection dropped
    
    sQML Debugger: Resolving host
    sQML Debugger: Establishing network connection ...
    
    sQML Debugger: Network connection dropped
    
    sQML Debugger: Resolving host
    sQML Debugger: Establishing network connection ...
    
    sQML Debugger: Network connection dropped
    
    sQML Debugger: Resolving host
    sQML Debugger: Establishing network connection ...
    
    sQML Debugger: Network connection dropped
    
    sQML Debugger: Resolving host
    sQML Debugger: Establishing network connection ...
    
    sQML Debugger: Network connection dropped
    
    sQML Debugger: Resolving host
    sQML Debugger: Establishing network connection ...
    
    sQML Debugger: Network connection dropped
    
    sQML Debugger: Resolving host
    sQML Debugger: Establishing network connection ...
    
    sQML Debugger: Network connection dropped
    
    sQML Debugger: Resolving host
    sQML Debugger: Establishing network connection ...
    
    sQML Debugger: Network connection dropped
    
    sQML Debugger: Resolving host
    sQML Debugger: Establishing network connection ...
    
     *** WARNING: Unable to verify checksum for C:\Qt\5.7\msvc2015_64\bin\Qt5Cored.dll
    
    sQML Debugger: Network connection dropped
    
    sModule loaded: C:\Qt\5.7\msvc2015_64\plugins\qmltooling\qmldbg_serverd.dll
    


  • I figured it out: A slow or buggy microsoft symbol server. I had in my Symbols Paths:

    srv*http://msdl.microsoft.com/download/symbols
    cache*C:\temp\SymbolCache
    

    Setting this to:

    cache*C:\temp\SymbolCache
    srv*http://msdl.microsoft.com/download/symbols
    

    Has sped things up back to normal. I recently had to reinstall due to during an upgrade there was still one Qt Creator running and broke things. I guess I didn't set everything back exactly. All good now though.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.