[Moved] Qt Creator saying no valid qt versions found please add a qt version when creating a new project



  • I have disabled guard32.dll from auto-running and then turned comodo into training mode, after that I restarted and now... I do not have qt version as earlier and Even though I have qt..bin in PATH I do not have it marked like that in qt versions dialog. WTF !?



  • [quote author="lordmonkey" date="1309523486"]I have disabled guard32.dll from auto-running and then turned comodo into training mode, after that I restarted and now... I do not have qt version as earlier and Even though I have qt..bin in PATH I do not have it marked like that in qt versions dialog. WTF !?[/quote]

    So, did you try to manually add it if its not detecting it from PATH...


  • Moderators

    "QTCREATORBUG-5248":http://bugreports.qt.nokia.com/browse/QTCREATORBUG-5248 is fixed in the 2.3 branch: We now warn about missing tool chains in the Qt version options page, so this issue should be much easier to discover.



  • ok so i have removed everything concerning qt from environment variables, reinstalled both qt and mingw libraries. Now I have folder structure like this :

    !http://img838.imageshack.us/img838/5480/unledvyi.png!

    which path i should add manually to path and i should add it to user path or system path ?


    EDIT:
    ok so I have added C:\qt\4.7.3\bin to both system and user path variables. Now I attach my projects build settings :
    !http://img534.imageshack.us/img534/5882/unledyf.png!

    and I have restarted and all the other things.



  • If you observe your Tool chain field, its empty . You need to add path to your g++.exe under ToolChains Options.

    1. In Qt Creator -> Tools -> Options.. -> Tool Chains ( In the left hand side)
    2. Click on "Add" button -> minGW -> it should add a row to "Manual" tool chains.
    3. Select that new row, and in Compiler path browser the path to g++.exe

    You should be able to find g++.exe in MinGW\bin\g++.exe. Select this path.

    Now in your Projects view select this newly created Tool Chain under "Tool chain".

    If Qt version is not detected automatically from PATH variable, add it manually.



  • Do you get anything in the drop down list of "Qt Versions" in the above page. If you get, you should select that.
    Can you go to 1) In Qt Creator -> Tools -> Options.. -> Qt to see if there are Qt added from the path (Atuo-detected).


  • Moderators

    Note that only tool chains that are actually compatible with your Qt version are offered. So if you do not get a tool chain for your Qt version, please make sure you installed the right mingw (e.g. a 32bit mingw for a 32bit Qt).

    Of course you could also just use the Qt SDK: That contains a Mingw Qt plus a Mingw compiler that actually works with it.



  • Ok so I have done what Vijay Bhaska Reddy said and now instead of 2 errors while buildin my already created project i have one (it's on the bottom of the screen I attach). but still "no qt version" even though it's added to path and to Qt Creator -> Tools -> Options.. -> Qt

    !http://img823.imageshack.us/img823/4303/unledfhk.png!



  • Can you show us your Projects and Tool chains screenshots...


  • Moderators

    Could you please hover the Qt version you want to use and check the ABI field there?

    Please go to the tool chains then and make sure a tool chain for that ABI is defined.



  • ok so in the meantime I have ininstalled qt and installed it from the qt SDK package and first of all I was getting these strange errors about (somtehing like)
    error during installation process.... maybe c:\qtsdk is blocked by another process

    now I get the same error about not having a qt version and my Qt maintenance manager (updater) looks like this

    !http://img405.imageshack.us/img405/4497/unled1jy.png!


    EDIT :
    ok so I have reinstalled sdk again with DEFAULT ssettings and everything is ok besides this segfault again :/
    I wonder what was I unchecking to make qt state: no qt version installed.

    should I install something else ?



  • OK .... SO ... my ultimate solution to this problem is

    • install QT SDK with default settings (even though you don't want most of the stuff that's in there)
    • uninstall COMODO Firewall ( internet security or whatever other program you have from COMODO) because even trying to disable guard32.dll with Autoruns or any other program it failed and I was getting the same seg fault over and over again.

    Thanks guys for help but ultimately I will just install other firewall so that I can code in Qt ;)



  • Finally welcome to Qt world

    EDIT: if you are able to install and make it work with out firewall.



  • hi guys ..
    can you give me sample codes that can randomize the position of the three objects??
    thanks in advance ..



  • [quote author="jhayar02" date="1309880283"]hi guys ..
    can you give me sample codes that can randomize the position of the three objects??
    thanks in advance ..[/quote]

    Wow.. should there be a new thread for this?. The original post is about Qt installation.



  • im new in qt creator..
    i just wanted to have some example to create a games using this software ..
    can u help me?



  • [quote author="jhayar02" date="1309881021"]im new in qt creator..
    i just wanted to have some example to create a games using this software ..
    can u help me?[/quote]

    Do you have Qt SDK installed? if not, go to http://qt.nokia.com/downloads and get Qt SDK 1.1.2 for your platform and install it. And then if you are new to Qt, get to know some basics of Qt and write few sample program.

    May be "How can you get Started?" section of http://qt.nokia.com/ is good place to start.



  • i already have Qt SDK ..
    i just wanted to have a sample codes that can randomize the movement of the three objects ..
    :)) ..



  • Hello.
    I installed new Kubuntu 11.10 and then QtCreator.
    I got subj message when I try to open any project and then can't open it.
    I have Auto-detected Qt in PATH /usr/bin/qmake-qt4 in options
    and
    /usr/bin$ ls -l | grep qmake
    lrwxrwxrwx 1 root root 23 2011-10-31 10:48 qmake -> /etc/alternatives/qmake
    -rwxr-xr-x 1 root root 3446992 2011-09-30 15:26 qmake-qt4

    I have this problem on two different PC with fresh Kubuntu 11.10 installation.

    There was no such problem on Kubuntu 11.4

    Is it a bug in new QtCreator version?
    Please help to resolve problem.



  • I resolved the problem.
    the g++ compiler was not installed, gcc was.
    After installing g++ QtCreator start to open projects normally.

    I think this is the bug in QtCreator.
    They should add g++ to dependences or change subj error message to more correctly one.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.