Important: Please read the Qt Code of Conduct -

Fatal error: No such file or directory - Windows 7 64-bit Qt cross-compile for Raspberry Pi 2

  • I´m trying to cross-compile Qt 5.5.0 for the Raspberry Pi 2 following this tutorial:

    On windows7 32-bit everything worked fine, but trying to build qt-everywhere-opensource-src-5.5.0 on a 64-bit system leads to the following error during "make".

    In file included from C:/Users/User/Documents/Raspberry/Resources/qt-everywhere-opensource-src-5.5.0/qtbase/src/platformsupport/eglconvenience/qeglplatformwindow.cpp:35:0: C:/Users/User/Documents/Raspberry/Resources/qt-everywhere-opensource-src-5.5.0/qtbase/include/QPlatformSupport/5.5.0/QtPlatformSupport/private/qopenglcompositor_p.h:1:87: fatal error: ../../../../../src/platformsupport/platformcompositor/qopenglcompositor_p.h: No such file or directory #include "../../../../../src/platformsupport/platformcompositor/qopenglcompositor_p.h" ^ compilation terminated.

    The relative path is correct, but still the respective file isn´t found. Changing the content of qopenqlcompositor_p.h and replacing the relative path with an absolute path like "#include "C:/Users/Users/Documents/Raspberry/Resources/qt-everywhere-opensource-src-5.5.0-new/qtbase/src/platformsupport/platformcompositor" solves the problem at first, but in the next run "make" terminates due to another fatal error which refers to a different include file that also contains a relative path.

    I ran configure with the following arguments:

    -platform win32-g++ -xplatform linux-arm-gnueabi-g++ -release -opengl es2 -device linux-rasp-pi2-g++ -sysroot C:/SysGCC/Raspberry/arm-linux-gnueabihf/sysroot -prefix /usr/local/qt5 -device-option CROSS_COMPILE=C:/SysGCC/Raspberry/bin/arm-linux-gnueabihf- -qt-xcb -qt-xkbcommon -xkb-config-root C:/SysGCC/Raspberry/arm-linux-gnueabihf/sysroot/usr/share/X11/xkb -qpa xcb

    Thank you very much for your help!

  • Update: I meanwhile managed to build qt 5.5 after going through all include files and replacing the relative paths with the correct absolute path.

    Additionally I shortened my paths building qt in C:/qt-5.5.0, because after changing the include expressions "make" terminated with another error.

    Assembler messages:
    Fatal error: can´t create .obj/Users/User/Documents/Raspberry/Resources/qt-everywhere-opensource-src-5.5.0‌​/qtimageformats/src/3rdparty/libwebp/src/dec/alpha.obj: No such file or directory
    C:/Users/User/Documents/Raspberry/Resources/qt-everywhere-opensource-src-5.5.0‌​/qtimageformats/src/3rdparty/libwebp/src/dec/alpha.c:165:1: fatal error: error writing to -: No error
    compilation terminated.

    Does Anyone know an easier solution?

Log in to reply