Трудности с Qwebengine



  • В проекте много разного железа, которое имеет свои web-сайты.
    До перехода на версию 5.7 использовал qwebkit для отображения страниц и все было хорошо, Но теперь webkit ликвидирован. В webengine отсутствует поддержка npapi (его используют все web-сайты моих железок). Переход на 5.7 обусловлен наличием новых протоколов и нужного функционала.
    Какие есть альтернативны?
    ActiveX Browser работает некорректно ибо никто из разработчиков железа не думал об internet explorer.
    P.S. Пример одной из железок - видеорегистратор. Разработка под Win7x32 msvc13



  • QtWebKit не "ликивидирован". Можно собрать из исходников версию 5.7.0 [1]. Кроме того, я разрабатываю новую версию QtWebKit, основанную на движке 2016 года, но в ней пока не реализована поддержка NPAPI, и поддерживается только VS2015 [2]

    [1] http://download.qt.io/community_releases/5.7/5.7.0/
    [2] http://lists.qt-project.org/pipermail/development/2016-June/026282.html
    https://github.com/annulen/webkit/wiki/Comparison-with-QtWebKit-5.6



  • Не попадались исходники, спасибо.
    Послежу за Вашим проектом :)

    Собрал под qt 5.7, все работает.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.