Touchscreen issue with tslib1.4, please kindly help this.



  • Dear all,

    I have faced an issue with the tslib1.4 with qt4.8.6.

    1. i have compile and install tslib1.4, and copy the tslib/lib to my embedded board. i run ts_calibrate and ts_test. They all works well.

    2. i compile qt4.8.6 with -qt-mouse-tslib, and copy the libs to the embedded board. and set all necessary environment variables.
      run the demo app calculator, from ./example/widget/calculator. the calculator show up, but not response when touch the screen.

    3. i use the "dexdump /dev/input/touchscreen0", it had outcomes.

    4. when i set
      export QWS_MOUSE_PROTO="MouseMan:/dev/input/mouse0"
      it had response when i touch the screen, but the X/Y coordinate seems not correct. because the cursor moved not exactly where i touched.
      but when i set :
      export QWS_MOUSE_PROTO="Tslib:/dev/input/touchscreen0"
      the touchscreen did not reponse.

    5. cat both /dev/input/touchscreen and /dev/input/mouse0, they all have outcomes when i touch the screen. but there is not mouse exist,

    could any one help me on this?
    Thanks.


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Did you also set all the Tslib environment variables before running your application ?



  • I solved my problem on QT 4.8 using this:
    export QWS_MOUSE_PROTO="linuxinput:/dev/input/touchscreen0"

    I used "linuxinput" instead of "tslib".

    If you execute "ts_test", the touch works?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.