Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

OSX - clang++ linker hanging at end



  • Anyone every run into this problem?

    Two different laptops, both running latest XCode/OSX/Qt/QtCreator, same project, same installation directories.

    On one Mac, everything works great, the other - linker hangs.

    Makefile hangs at the end of the linking stage - if I shell to the target directory, the app and everything is there - but QtCreator is hung. When I clean and build the application via the command by just running 'make' - same result. Complete application, in the correct place, but the terminal I am building in is hung at the end of the linking step.

    I'm going to compare the makefiles later, but has anyone run into this before? (I don't think this has anything to do with Qt, because I can build samples just fine on both machines.)

    Thanks :)


  • Lifetime Qt Champion

    Hi,

    Strange indeed… What version of OS X/Xcode/QtCreator are you using ?



  • I'm going to ensure I'm creating identical makefiles, and double check the versions. The primary difference is that one is a work laptop (with all kinds of corporate controls installed on it) and the other is a personal laptop. Guess which one works fine? ;)

    Thanks @SGaist - I'll debug further without bothering anyone - I just wanted to know if this was something that long time Qt/OSX devs would say "Oh, yeah, it's a permissions thing" (or similar.)

    I'll update this thread as I go along.

    Cheers!



  • After checking a ton of things, ultimately I simply decided to un-install XCode and re-install it (very 'Windows circa 2006'-ish) and bingo - worked.


  • Lifetime Qt Champion

    Oo well… Surprising but at least you can now hack !

    Since you have it working now, please mark the thread as solved using the "Topic Tool" button so that other forum users may know a solution has been found :)



  • @SGaist Weird, I had a question the other day I wanted to marked 'solved' and I asked another user about it and they said the forum had dropped that capability and now you could only upvote responses - did that change back or did that never actually go away?


  • Lifetime Qt Champion

    No, it never went away.

    What might happen is that when you create a new thread you have two possibilities: normal topic or question. The solved option only appears if you "asked as question". However you can always change afterward between normal and question.


Log in to reply