Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

[Solved] Qt Creator 2.2.1 on Ubuntu 11.04: the GUI is messed up



  • Hello,

    I just installed Qt Creator 2.2.1 from the website download and the GUI is somewhat messed up. The menu looks a bit funny, but worst is in the Project page and Options dialog box: the buttons are gone only the button labels are there, the drop down boxes are gone with the choices are visible but not usable. I would post a pic but I did not find how to do it.

    I had 2.1.0 before that I installed from repository and it worked fine.

    Do you know what's up with 2.2.1 and if there is an easy fix for it?

    THX!


  • Moderators

    Most likely the ubuntu theme is causing this trouble.

    Try running Qt Creator with "-style plastique" and see whether that fixes the issue. Please file a bug against the gtk style in your installed Qt version in that case.



  • That worked - thank you!!



  • Can I set that style permanently?



  • I had a similar behaviour on debian squeeze with KDE when i used configure without options.

    This is how i solved it permanently:
    i looked in the mkspecs subfolder for the qtconfig.pri file of the qt debian package. I made sure i had the same options when using configure as in the QT_CONFIG line and the result was a nice and shiny Qt Creator 2.2.1.



  • I do not have such config file and I cannot easily find anything similar. I added the style to the command line that will work for now.

    How can I mark this thread as solved?



  • You can edit the first post and add [Solved] in front of the thread title



  • Thanks.

    I reported the bug.



  • bq. I do not have such config file and I cannot easily find anything similar.

    Sorry my mistake. I thought you used the sources and compiled Qt yourself. I see in your first post now you used the installer.



  • bq. Can I set that style permanently?

    you could add an item to your kubuntu menu and use the command Tobias gave you :
    "/yourQtPath/qtcreator -style plastique"
    in it



  • [quote author="Eddy" date="1308687872"]bq. Can I set that style permanently?
    you could add an item to your kubuntu menu and use the command Tobias gave you :
    "/yourQtPath/qtcreator -style plastique"
    in it[/quote]

    That's what I did, except I use GNOME.

    Thanks.



  • You're welcome.
    I typed one "k" to much. but it all stays in the same family ;)


Log in to reply