QtCreator on OSX - qmake always producing a Makefile targeting 10.7 instead of 10.9



  • I'm trying to link to a 3rd party library on OSX that was built and linked for OSX 10.9.

    Apparently qmake is generating a min version of OSX of 10.7.

    I have tried changing this via my *.pro file with:

    QMAKE_CXXFLAGS += -mmacosx-version-min=10.9
    LIBS += -mmacosx-version-min=10.9

    (I don't know if the LIBS specifier does anything but somebody else who had this problem a long time ago had this in theirs so what the hell. I tried without it and same issues.)

    I have also tried editing the Qbs for the Clang 64-bit kit and changing the kit profile 's cpp.minimumOsxVersion key from 10.7 to 10.9.

    It replaced the original key, and it shows "10.9" in red (presumably to show that I'd customized it.)

    No matter what I do the resulting qmake Makefile specifies the minimum version as 10.7 - literally this is in the makefile everywhere: "-mmacosx-version-min=10.7"

    If I go and hand edit the Makefile and change all the 10.7 instances to 10.9, everything builds just fine. But I can't merge code that has to be hand edited...

    What am I missing?

    Thanks.



  • BTW, I've gotten past this by removing 5.6 and installing 5.7; ergo, it may have been the new QtCreator, or some other aspect of the tool chain - or I may have been able to resolve it by removing 5.6 and re-installing 5.6 (I'll never know...)

    Some day when I'm not working on a Saturday I'll try out changing it to another version and seeing how well that works in the Makefile (but not today.)


  • Lifetime Qt Champion

    Hi,

    If you want to change the deployment target, you can use QMAKE_MACOSX_DEPLOYMENT_TARGET.

    Hope it helps


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.