Qt Creator not listed in applications under Ubuntu16.04



  • I tried to install Qt Creator via the terminal, Software Centre and the installation .run-file provided by Qt.
    Although Qt Linguist, Qt Designer and Qt Assistant appears on every three ways of installing Qt Creator is only accessible via typing qtcreator in the terminal except for solution (3).
    Is this a bug in the current version? How to fix that?



  • I just tried via the terminal using:

    sudo apt-get install qtcreator
    

    on Ubuntu 16.04, and "Qt Creator" appeared under the "Programming" list in the Menu popup (using Cinnamon 3.0.4).

    The last line of the apt-get output said:

    Processing triggers for menu (2.1.47ubuntu1) ...
    

    I suspect that's when its adding the menu item(s). Did you see that output when you installed via the CLI?

    What desktop environment are you using? Unity or something else? (Shouldn't really matter, but worth checking)



  • It is just the Ubuntu standard installation using Unity.

    I just reinstalled it. Here is the output:

    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following packages were automatically installed and are no longer required:
      linux-headers-4.2.0-36 linux-headers-4.2.0-36-generic
      linux-image-4.2.0-36-generic linux-image-extra-4.2.0-36-generic
    Use 'sudo apt autoremove' to remove them.
    The following additional packages will be installed:
      icu-devtools libbotan-1.10-1 libclang1-3.6 libicu-dev libllvm3.6v5
      libobjc-5-dev libobjc4 libqbscore1 libqbsqtprofilesetup1 libqt5concurrent5
      libqt5designercomponents5 libqt5quickwidgets5 libqt5xmlpatterns5
      qml-module-qtquick-controls qt5-qmake qtbase5-dev-tools qtcreator
      qtcreator-data qttools5-dev-tools qtxmlpatterns5-dev-tools
    Suggested packages:
      icu-doc kdelibs5-data subversion ubuntu-sdk
    The following NEW packages will be installed:
      icu-devtools libbotan-1.10-1 libclang1-3.6 libicu-dev libllvm3.6v5
      libobjc-5-dev libobjc4 libqbscore1 libqbsqtprofilesetup1 libqt5concurrent5
      libqt5designercomponents5 libqt5quickwidgets5 libqt5xmlpatterns5
      qml-module-qtquick-controls qt5-qmake qtbase5-dev-tools qtcreator
      qtcreator-data qtcreator-dev qttools5-dev-tools qtxmlpatterns5-dev-tools
    0 upgraded, 21 newly installed, 0 to remove and 11 not upgraded.
    Need to get 0 B/44,1 MB of archives.
    After this operation, 197 MB of additional disk space will be used.
    Do you want to continue? [Y/n] 
    Selecting previously unselected package qml-module-qtquick-controls:amd64.
    (Reading database ... 312336 files and directories currently installed.)
    Preparing to unpack .../qml-module-qtquick-controls_5.5.1-1ubuntu1_amd64.deb ...
    Unpacking qml-module-qtquick-controls:amd64 (5.5.1-1ubuntu1) ...
    Selecting previously unselected package icu-devtools.
    Preparing to unpack .../icu-devtools_55.1-7_amd64.deb ...
    Unpacking icu-devtools (55.1-7) ...
    Selecting previously unselected package libbotan-1.10-1.
    Preparing to unpack .../libbotan-1.10-1_1.10.12-1_amd64.deb ...
    Unpacking libbotan-1.10-1 (1.10.12-1) ...
    Selecting previously unselected package libllvm3.6v5:amd64.
    Preparing to unpack .../libllvm3.6v5_1%3a3.6.2-3ubuntu2_amd64.deb ...
    Unpacking libllvm3.6v5:amd64 (1:3.6.2-3ubuntu2) ...
    Selecting previously unselected package libobjc4:amd64.
    Preparing to unpack .../libobjc4_5.3.1-14ubuntu2.1_amd64.deb ...
    Unpacking libobjc4:amd64 (5.3.1-14ubuntu2.1) ...
    Selecting previously unselected package libobjc-5-dev:amd64.
    Preparing to unpack .../libobjc-5-dev_5.3.1-14ubuntu2.1_amd64.deb ...
    Unpacking libobjc-5-dev:amd64 (5.3.1-14ubuntu2.1) ...
    Selecting previously unselected package libclang1-3.6:amd64.
    Preparing to unpack .../libclang1-3.6_1%3a3.6.2-3ubuntu2_amd64.deb ...
    Unpacking libclang1-3.6:amd64 (1:3.6.2-3ubuntu2) ...
    Selecting previously unselected package libicu-dev:amd64.
    Preparing to unpack .../libicu-dev_55.1-7_amd64.deb ...
    Unpacking libicu-dev:amd64 (55.1-7) ...
    Selecting previously unselected package libqbscore1.
    Preparing to unpack .../libqbscore1_1.4.5+dfsg-2_amd64.deb ...
    Unpacking libqbscore1 (1.4.5+dfsg-2) ...
    Selecting previously unselected package libqbsqtprofilesetup1.
    Preparing to unpack .../libqbsqtprofilesetup1_1.4.5+dfsg-2_amd64.deb ...
    Unpacking libqbsqtprofilesetup1 (1.4.5+dfsg-2) ...
    Selecting previously unselected package libqt5concurrent5:amd64.
    Preparing to unpack .../libqt5concurrent5_5.5.1+dfsg-16ubuntu7.1_amd64.deb ...
    Unpacking libqt5concurrent5:amd64 (5.5.1+dfsg-16ubuntu7.1) ...
    Selecting previously unselected package libqt5designercomponents5:amd64.
    Preparing to unpack .../libqt5designercomponents5_5.5.1-3build1_amd64.deb ...
    Unpacking libqt5designercomponents5:amd64 (5.5.1-3build1) ...
    Selecting previously unselected package libqt5quickwidgets5:amd64.
    Preparing to unpack .../libqt5quickwidgets5_5.5.1-2ubuntu6_amd64.deb ...
    Unpacking libqt5quickwidgets5:amd64 (5.5.1-2ubuntu6) ...
    Selecting previously unselected package libqt5xmlpatterns5:amd64.
    Preparing to unpack .../libqt5xmlpatterns5_5.5.1-2build1_amd64.deb ...
    Unpacking libqt5xmlpatterns5:amd64 (5.5.1-2build1) ...
    Selecting previously unselected package qt5-qmake:amd64.
    Preparing to unpack .../qt5-qmake_5.5.1+dfsg-16ubuntu7.1_amd64.deb ...
    Unpacking qt5-qmake:amd64 (5.5.1+dfsg-16ubuntu7.1) ...
    Selecting previously unselected package qtbase5-dev-tools.
    Preparing to unpack .../qtbase5-dev-tools_5.5.1+dfsg-16ubuntu7.1_amd64.deb ...
    Unpacking qtbase5-dev-tools (5.5.1+dfsg-16ubuntu7.1) ...
    Selecting previously unselected package qtcreator-data.
    Preparing to unpack .../qtcreator-data_3.5.1+dfsg-2ubuntu2_all.deb ...
    Unpacking qtcreator-data (3.5.1+dfsg-2ubuntu2) ...
    Selecting previously unselected package qtcreator.
    Preparing to unpack .../qtcreator_3.5.1+dfsg-2ubuntu2_amd64.deb ...
    Unpacking qtcreator (3.5.1+dfsg-2ubuntu2) ...
    Selecting previously unselected package qtcreator-dev.
    Preparing to unpack .../qtcreator-dev_3.5.1+dfsg-2ubuntu2_all.deb ...
    Unpacking qtcreator-dev (3.5.1+dfsg-2ubuntu2) ...
    Selecting previously unselected package qttools5-dev-tools.
    Preparing to unpack .../qttools5-dev-tools_5.5.1-3build1_amd64.deb ...
    Unpacking qttools5-dev-tools (5.5.1-3build1) ...
    Selecting previously unselected package qtxmlpatterns5-dev-tools.
    Preparing to unpack .../qtxmlpatterns5-dev-tools_5.5.1-2build1_amd64.deb ...
    Unpacking qtxmlpatterns5-dev-tools (5.5.1-2build1) ...
    Processing triggers for man-db (2.7.5-1) ...
    Processing triggers for libc-bin (2.23-0ubuntu3) ...
    Processing triggers for hicolor-icon-theme (0.15-0ubuntu1) ...
    Processing triggers for shared-mime-info (1.5-2) ...
    Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20160523-0ubuntu1) ...
    Rebuilding /usr/share/applications/bamf-2.index...
    Processing triggers for gnome-menus (3.13.3-6ubuntu3) ...
    Processing triggers for desktop-file-utils (0.22-1ubuntu5) ...
    Processing triggers for mime-support (3.59ubuntu1) ...
    Setting up qml-module-qtquick-controls:amd64 (5.5.1-1ubuntu1) ...
    Setting up icu-devtools (55.1-7) ...
    Setting up libbotan-1.10-1 (1.10.12-1) ...
    Setting up libllvm3.6v5:amd64 (1:3.6.2-3ubuntu2) ...
    Setting up libobjc4:amd64 (5.3.1-14ubuntu2.1) ...
    Setting up libobjc-5-dev:amd64 (5.3.1-14ubuntu2.1) ...
    Setting up libclang1-3.6:amd64 (1:3.6.2-3ubuntu2) ...
    Setting up libicu-dev:amd64 (55.1-7) ...
    Setting up libqbscore1 (1.4.5+dfsg-2) ...
    Setting up libqbsqtprofilesetup1 (1.4.5+dfsg-2) ...
    Setting up libqt5concurrent5:amd64 (5.5.1+dfsg-16ubuntu7.1) ...
    Setting up libqt5designercomponents5:amd64 (5.5.1-3build1) ...
    Setting up libqt5quickwidgets5:amd64 (5.5.1-2ubuntu6) ...
    Setting up libqt5xmlpatterns5:amd64 (5.5.1-2build1) ...
    Setting up qt5-qmake:amd64 (5.5.1+dfsg-16ubuntu7.1) ...
    Setting up qtbase5-dev-tools (5.5.1+dfsg-16ubuntu7.1) ...
    Setting up qtcreator-data (3.5.1+dfsg-2ubuntu2) ...
    Setting up qtcreator (3.5.1+dfsg-2ubuntu2) ...
    Setting up qtcreator-dev (3.5.1+dfsg-2ubuntu2) ...
    Setting up qttools5-dev-tools (5.5.1-3build1) ...
    Setting up qtxmlpatterns5-dev-tools (5.5.1-2build1) ...
    Processing triggers for libc-bin (2.23-0ubuntu3) ...
    
    

    The only thing appeared was;: Processing triggers for gnome-menus (3.13.3-6ubuntu3) ...

    I guess the problem is that there is no entry for Unity..



  • Any ideas what went wrong here?


  • Moderators

    Can you find QtCreator if you press Win key and type QtCreator?



  • No, that’s why I posted here in the forum. ;)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.