SSL service error in Android 6.01



  • We are using Arcgis Runtime SDK for Qt 10.2.6 and Qt 5.4.2 (MSVC 2013, 32 bit) Qt Creator QT\QML side. And we are develop and deploy Adroid app with **Android Armeobi-v7a (GCC4.9 , QT 5.4.2) ** kid.

    Error ocureed when I update My Android OS to 6.01 and then when I tried to use services .Here is the console output below.:

    D MenuDenemeNumarataj: (null):0 ((null)): int main(int, char**) ApplicationWindow_QMLTYPE_165_QML_191(0x9bbe2460)
    D mali_winsys: new_window_surface returns 0x3000, [1536x2000]-format:1
    D libGLESv2: DTS_GLAPI : DTS is not allowed for Package : com.mycompany.myappname
    D ViewRootImpl: ViewPostImeInputStage processPointer 0
    D ViewRootImpl: ViewPostImeInputStage processPointer 1
    F libc : Fatal signal 11 (SIGSEGV), code 1, fault addr 0x8 in tid 20871 (QtThread)

    How Can I solve this problem ?

    Thanks



  • We are using below code (in Main) for passing certificate like below to solve problem but We can'not solve problem in 6.0.1 version:

    QSslConfiguration config = QSslConfiguration::defaultConfiguration();
    config.setPeerVerifyMode(QSslSocket::VerifyNone);
    QSslConfiguration::setDefaultConfiguration(config);

    We have Galaxy Tab 2 and our application is correct working (wcf login services) in Android Operating System 5.0.2 Version but when I update My Android OS to 6.0.1 and then when I tried to use wcf (login) services gives exception .How can I solve this important problem because is important for us ?

    There is some pages to solve problem in line in below but we develope Qt/QML android application in Windows OS Are there any solved example in Windows not Linux or how to solve problem in Windows Os any idea or example ?

    http://doc.qt.io/qt-5/opensslsupport.html

    Thanks.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.