Ubuntu 16.04 LTS, QT 5.6.1, Gstreamer 1.0 = no service found for "org.qt-project.qt.mediaplayer"



  • Hi,

    I am using:

    • Ubuntu 16.04 LTS
    • Gstreamer 1.0 packages
    • QT 5.6

    I downloaded the latest online run-installer from the webpage and installed QT 5.6 using the maintenance tool.
    Everything installed fine.

    But running my c++/qt quick application (or even the included multimedia video example) which utilizes QtMultimedia 5.6. I get the following output when I try to open a video:

    QtMultimedia : defaultServiceProvider::requestService(): no service found for "org.qt-project.qt.mediaplayer"
    

    I have spent hours searching the internet now but all the issues are old, related to gstreamer or configure.
    At this point I have no idea what the problem could be, any suggestion is helpful.
    (no need to say that the default linux video player has no problem opening the video I am trying to open with QT)


  • Lifetime Qt Champion

    Hi,

    Did you also install the GStreamer plugin packages ?



  • @SGaist Please notice that I updated the question. I am testing different ways.
    @SGaist At this point I have installed everything with gstreamer I could find.
    Below is the complete list of installed packages on the machine:

    dpkg --get-selections | grep -v deinstall | grep gstream
    
    gir1.2-gstreamer-1.0   			     install
    gstreamer1.0-alsa:amd64   			 install
    gstreamer1.0-clutter-3.0   		 	 install
    gstreamer1.0-fluendo-mp3:amd64  	 install
    gstreamer1.0-libav:amd64   			 install
    gstreamer1.0-nice:amd64   			 install
    gstreamer1.0-plugins-bad:amd64   		 install
    gstreamer1.0-plugins-bad-faad:amd64   	 install
    gstreamer1.0-plugins-bad-videoparsers:amd64    install
    gstreamer1.0-plugins-base:amd64   		 install
    gstreamer1.0-plugins-base-apps   		 install
    gstreamer1.0-plugins-good:amd64   		 install
    gstreamer1.0-plugins-ugly:amd64   		 install
    gstreamer1.0-plugins-ugly-amr:amd64   	 install
    gstreamer1.0-pulseaudio:amd64   		 install
    gstreamer1.0-tools   				     install
    gstreamer1.0-x:amd64   			         install
    libgstreamer-plugins-bad1.0-0:amd64   	 install
    libgstreamer-plugins-base1.0-0:amd64   	 install
    libgstreamer-plugins-base1.0-dev   		 install
    libgstreamer-plugins-good1.0-0:amd64   	 install
    libgstreamer1.0-0:amd64   		     	 install
    libgstreamer1.0-dev   				     install
    libreoffice-avmedia-backend-gstreamer  	 install
    

  • Lifetime Qt Champion

    Are you using a custom build of Qt ?

    If not and IIRC, Qt 5.6 still uses the old 0.1 GStreamer.



  • @SGaist the X11 requirements say also gstreamer-1.0 is supported:

    http://doc.qt.io/qt-5/linux-requirements.html

    The minimum required version of GStreamer is 0.10.24. The 1.x series is also supported.

    To build Qt Multimedia, you need the GStreamer library, base plugins, and development files for your system. To run applications that use Qt Multimedia, you might also need to install the following GStreamer plugins: 'good', 'ugly', 'bad', ffmpeg (0.10), and libav (1.x).

    If the op is not using X11 I had the same problem (w/ gstreamer-1.0) solved compiling also the opengl module.


  • Lifetime Qt Champion

    Supported yes, but you have to re-build the GStreamer backend to use it.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.