QT Creator build error using mingw64 (Unknown module(s) in QT: script)



  • Hello. I have successfully built QT 5.6.0 using this guide on the QT wiki:
    https://wiki.qt.io/MinGW-64-bit

    Using the following configuration:

    configure -debug-and-release -opensource -confirm-license -platform win32-g++ -developer-build -c++std c++14 
    -icu -opengl desktop -openssl -plugin-sql-odbc -qt-style-windowsxp -qt-style-windowsvista -nomake tests
    

    Now I am trying to compile QT Creator. When I run qmake, it generates the makefile fine. However, when I try to compile it using mingw32-make I run into the following error.

    cd src\ && ( if not exist Makefile C:\Prog\Libraries\qt5\5.6.0\qtbase\bin\qmake.exe C:\Prog\Apps\qt-creator\src\src.pro -o Makefile ) && mingw32-make -f Makefile
    mingw32-make[1]: Entering directory 'C:/Prog/Apps/qt-creator/src'
    cd shared\qbs\src\lib\corelib\ && ( if not exist Makefile C:\Prog\Libraries\qt5\5.6.0\qtbase\bin\qmake.exe C:\Prog\Apps\qt-creator\src\shared\qbs\src\lib\corelib\corelib.pro -o Makefile ) && mingw32-make -f Makefile
    Project ERROR: Unknown module(s) in QT: script
    Makefile:49: recipe for target 'sub-shared-qbs-src-lib-corelib-make_first-ordered' failed
    mingw32-make[1]: *** [sub-shared-qbs-src-lib-corelib-make_first-ordered] Error 3
    mingw32-make[1]: Leaving directory 'C:/Prog/Apps/qt-creator/src'
    Makefile:39: recipe for target 'sub-src-make_first-ordered' failed
    mingw32-make: *** [sub-src-make_first-ordered] Error 2
    

    After looking around, it seems I am missing a script module of sorts I think, but I have no idea on how to resolve that problem with my current setup. My OS is Windows 10.


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    QtScript has been deprecated in Qt 5.5 and removed from distribution in Qt 5.6. You have to build the module yourself.



  • Thanks! Got it to work.

    For those that are having the same problem that stumble upon this, clone qtscript from the repository and build it following the same instructions in the readme for qtcreator. Then you can use the same command prompt to continue building qtcreator after that is done. I also needed to build qttools from the repository after I got a "Project ERROR: Unknown module(s) in QT: help" error further along the build.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.