Important: Please read the Qt Code of Conduct -

Creator 4.0 fails to find qmake

  • I just updated Creator to 4.0 on Windows 7 and tried to build a simple project with Qt 5.6 mingw. I got this error:

    10:09:48: Running steps for project fonts...
    10:09:48: Configuration unchanged, skipping qmake step.
    10:09:48: Starting: "C:\Qt\Tools\mingw492_32\bin\mingw32-make.exe" 
    C:\Qt\5.6\mingw49_32\bin\qmake.exe -spec win32-g++ "CONFIG+=debug" "CONFIG+=qml_debug" -o Makefile ..\fonts\
    C:Qt5.6mingw49_32binqmake.exe: not found
    makefile:175: recipe for target 'Makefile' failed
    mingw32-make: *** [Makefile] Error 127
    10:09:49: The process "C:\Qt\Tools\mingw492_32\bin\mingw32-make.exe" exited with code 2.
    Error while building/deploying project fonts (kit: Desktop Qt 5.6.0 MinGW 32bit)
    When executing step "Make"
    10:09:49: Elapsed time: 00:01.

    Somehow the path to qmake is all messed up. All the back slashes are stripped.

  • Lifetime Qt Champion


    Did you do the update from the maintenance tool ?

  • @SGaist Yes. I did. I also removed and added the component with the same result.
    However, I added MSVC2013 32bit to the project and it didn't have the problem. Then I rebooted the machine and now both works.

  • Lifetime Qt Champion

    Good old reboot and everything is working again ? :)

Log in to reply