Important: Please read the Qt Code of Conduct -

Cannot launch my Qt application under wayland

  • Hello,

    I installed Qtcreator on my Debian testing using Qt maintenance tool. Everything worked fine, since I upgraded my system. Now I have Gnome-shell 3.20 that uses the wayland compositor.

    And when I try to launch my application, I have this error message : This application failed to start because it could not find or load the Qt platform plugin "xcb".

    I am almost sure it is related to this upgrade.

    How to install the required dynamic library that permits the program to be launched ? I looked at Qt maintenance tool, but there is no such thing.

    Thank you for helping. I shall give you other information you will need.

    EDIT: I use Qt creator 4.0.0 based on Qt 5.6.0

  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Just a wild guess but I think you have to build the QtWayland module if your shell is running under Wayland.

    Hope it helps

  • @SGaist Thank you for you reply.

    I tried to build it, but I got the message QtWayland requires Wayland 1.4.0 or higher, QtWayland will not be built. My version of wayland is the 1.3-1.

    So I think it is not possible on my system now to run the newest Qt applications.

    In the past, I already tried to use the version of the Debian repository, but it did not work. However I shall try in this direction again.

Log in to reply