Raspberry Pi guide Error



  • Hello.

    I am following this guide for cross-compiling to RPi, and it did work before, the last time I tried, but now, I am doing exactly the same steps and seeing an error. It fails almost at the and of making.

    Guide: http://wiki.qt.io/RaspberryPi_Beginners_Guide

    I run this:

    ./configure -device linux-rasp-pi-g++ -device-option CROSS_COMPILE=/media/Work/Work/ARM_Toolchain/gcc-4.7-linaro-rpi-gnueabihf/bin/arm-linux-gnueabihf- -sysroot /mnt/rasp-pi-rootfs -opensource -confirm-license -optimized-qmake -reduce-exports -release -make libs -prefix /usr/local/qt5pi -hostprefix /usr/local/qt5pi
    

    Then make on 8 cores:

    make -j 8
    

    And it fails with this:

    .obj/qlibrary_unix.o: In function `QLibraryPrivate::load_sys()':
    qlibrary_unix.cpp:(.text+0x12e0): warning: Using 'dlopen' in statically linked applications requires at runtime the shared libraries from the glibc version used for linking
    /mnt/rasp-pi-rootfs/usr/lib/arm-linux-gnueabihf/libdl.a(dlopen.o): In function `dlopen':
    (.text+0xc): undefined reference to `__dlopen'
    /mnt/rasp-pi-rootfs/usr/lib/arm-linux-gnueabihf/libdl.a(dlclose.o): In function `dlclose':
    (.text+0x0): undefined reference to `__dlclose'
    /mnt/rasp-pi-rootfs/usr/lib/arm-linux-gnueabihf/libdl.a(dlsym.o): In function `dlsym':
    (.text+0xc): undefined reference to `__dlsym'
    /mnt/rasp-pi-rootfs/usr/lib/arm-linux-gnueabihf/libdl.a(dlerror.o): In function `dlerror':
    (.text+0x0): undefined reference to `__dlerror'
    collect2: error: ld returned 1 exit status
    Makefile:1260: recipe for target '../../lib/libQt5Core.so.5.4.2' failed
    make[3]: *** [../../lib/libQt5Core.so.5.4.2] Error 1
    make[3]: Leaving directory '/media/Work/QT_Creator/5.4/Src/qtbase/src/corelib'
    Makefile:142: recipe for target 'sub-corelib-make_first' failed
    make[2]: *** [sub-corelib-make_first] Error 2
    make[2]: Leaving directory '/media/Work/QT_Creator/5.4/Src/qtbase/src'
    Makefile:45: recipe for target 'sub-src-make_first' failed
    make[1]: *** [sub-src-make_first] Error 2
    make[1]: Leaving directory '/media/Work/QT_Creator/5.4/Src/qtbase'
    Makefile:70: recipe for target 'module-qtbase-make_first' failed
    make: *** [module-qtbase-make_first] Error 2
    jurisl@YuriyLinuxPC /media/Work/QT_Creator/5.4/Src $
    

    Any ideas or tips would be highly appreciated.

    Regards.
    Yuriy.


  • Moderators

    Hi and welcome to the forum

    The question is what you have changed either the input such as the Qt source code version or something on your setup?



  • Hello again.

    It seems, that, this guide has to be updated to support Rasbian Jessie (new one), as Wheezy (old one) is not available on the official Pi Website anymore. It would also be good to support RASPBIAN JESSIE LITE, as small footprint is better for embedded coding.

    So the issue seems to be in Linux distro version, as official guide is based on older version of the OS, that is not available from Respberry Pi website anymore.

    Regards!


  • administrators

    Hi @RebelCoderRU

    As the article is in the wiki, it can be updated by anyone.
    So if you (or anyone else for that matter) figure out what to change, please do update the article to Jessie.

    Thanks!


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.