Qt crashing transferring app to IPhone



  • I'm building an app for IOS using Qt, it's not a regular job thingy, so sometimes I keep for a while without any update in the code. And every time I get back to it I get a new and surprising error.

    I was using Qt5.5 (Indie license) and Iphone 5S to build this QML app.

    After a couple months without touching the code I came back to it and tried to build and run on my IPhone just to check everything was ok.... was not.

    I got the following error:

    TransferAppSession(05d18047bac1b57a77081395686822ac451a0eee, /<path>/build-XpenseTrackr-iphoneos_clang_Qt_5_6_0_for_iOS-Debug/Debug-iphoneos/XpenseTrackr.app)startService on device 05d18047bac1b57a77081395686822ac451a0eee failed, AMDeviceStartService returned 3892314146
    TransferAppSession(05d18047bac1b57a77081395686822ac451a0eee, /<path>/build-XpenseTrackr-iphoneos_clang_Qt_5_6_0_for_iOS-Debug/Debug-iphoneos/XpenseTrackr.app)Bad file descriptor
    So I've tried to delete the app from the Iphone, delete the build folder and rebuild it from scratch Same error.

    Then I tried to update my Qt libs to Qt5.6 and Qt Creator to 3.6.1... no success, the same error popup on my face while I try to keep all my hairs on my head. I'm running on a MacOSX 10.10.5 (Yosemite) and I don't plan to upgrade soon.

    Hey, what about update XCode?

    Open AppStore
    Search for XCode
    Click on Update
    Look for the spinning running forever without anything take effect, no feedback, nothing is happening.
    Repeat
    No idea what else I can try and it's really frustrating that every time I need to worry about things not code-related, I really like and enjoy Qt/QML but my plan B is give up it and get something that give less issues and don't debit 20 euros/month from my credit card.

    Thanks


  • Lifetime Qt Champion

    Hi,

    Looks similar to QTCREATORBUG-12384

    Can you test the transfer from Xcode ?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.