Program database manager mismatch



  • Hello,

    I'm trying to get Qt set up and have been having one hell of a hard time.

    First I was getting an error that said I needed to set up a compiler even though it was set up. So I tried installing a previous version of the software.

    That led to the error that is the title of this post.

    C:\Users\nifty_000\Documents\Qt Projects\7DaysServerPro\main.cpp:-1: error: C1902: Program database manager mismatch; please check your installation

    C:\Users\nifty_000\Documents\Qt Projects\build-7DaysServerPro-Desktop_Qt_5_6_0_MSVC2015_64bit-Debug\debug\qrc_qml.cpp:-1: error: C1902: Program database manager mismatch; please check your installation

    I've spent the better part of the day just trying to solve these issues. I would very much appreciate any help anyone could offer.


  • Moderators

    Hi!
    Maybe this can help: https://msdn.microsoft.com/en-us/library/8y7hea02.aspx
    Also did you try a full rebuild?



  • I'm trying to find those files now to see if they match, but I'm a little new to this so I'm not sure.

    As far as a rebuild, do you mean reinstall? If so, I uninstalled all Qt versions and deleted the Qt folder in C: and reinstalled. Same error.


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    The "setup a compiler" error means that you don't have installed any compiler to the version of Qt you are trying to use. Most of the time it's because there's no matching version of Visual Studio installed. In your case, you need to install VS2015 since you downloaded Qt 5.6.0 for MSVC2015.

    As for the other error, the first thing I would do is remove the space you have in your path. Change Qt Projects for Qt_Projects. Paths with spaces have always been problematic on Windows.


  • Moderators

    @Nifty62 No, with rebuild I mean completely rebuild your project (in QtCreator in Build menu click on "Rebuild all").



  • I'm with you, this has been the hardest program to install ever. QT creator's page says that if you installed the suite, it should work out of the box. Do they even know what that means?

    After installing the latest QT creator, the latest VS 2015, I now have the c1902 error, and all of the "solutions" I have found are completely useless to me.

    It's like the QT community doesn't want an open community or something.

    What's the password to get in guys? Can I play too?

    Nifty62, did you ever get this working?


  • Qt Champions 2016

    @bauervision
    Hi and welcome

    If you want a out of the box working experience just dont use
    visual studio.

    Microsoft FORBIDS anyone to bundle it so you must set it up yourself self.

    You can use mingw setup and it will just work with no extra fiddling. :)


  • Moderators

    @bauervision Well, the password is: explain a bit more what you did. You installed VS2015 and QtCreator (which version?). Did you install Qt? If so which version and for which compiler?



  • @mrjj

    I installed QT suite as directed and the "works out of the box" simply didn't materialize.

    I installed mingw individually but that never got me past the:

    "QT Creator needs a compiler..." error.

    Looking through the few forums I could find on this topic, it seemed as though most people kept pointing to there not being a compiler installed, and suggesting to install VS, so I relented and once it finished, QT at least moved past the compiler issue--which I assumed would have been regarded as progress.

    I don't want to install VS. I want to use the QT suite as it is these tools that I have been directed to learn. I thought that maybe since I'm behind the firewall at work that maybe mingw was not installing properly, but I had the same results at home.



  • @jsulm

    QT Creator 4.0.0

    from here:

    https://www.qt.io/download-open-source/


  • Moderators

    @bauervision You can use the Qt online installer to install Qt, QtCreator and MinGW, then it should work out of the box (at least for me it was always working). Do not install MinGW by yourself, use Qt online installer.


  • Qt Champions 2016

    Ok, i never have had any issues with
    http://download.qt.io/official_releases/qt/5.6/5.6.1/qt-opensource-windows-x86-mingw492-5.6.1.exe.mirrorlist
    on windows.

    Are u sure u did check off the mingw compiler, ?
    the online installer is sometimes "helpful" and u can install
    Qt and no mingw compiler is
    actually checked but it is not really that clear.
    So if u try online installer again then, please look in tools
    to see if mingw compiler is checked.

    Or use the direct mingw+qt installer i linked.



  • @mrjj

    I'm uninstalling QT now, and will reinstall.

    Then use the link you suggested if it doesn't work from the online installer.

    Thanks everyone, sorry if I came off snarky, I'm just feeling the pressure to get this under my belt for work, and not being able to even run a simple Hello world app is very, very frustrating.


  • Qt Champions 2016

    @bauervision
    I cross fingers. :)
    Yes I know the feeling when tools dont work and all you wanna do is code not
    play "yet another re-install" :)



  • @mrjj

    Yes exactly.

    I noticed this time when I ran the installer, that it did NOT in fact have MinGW checked, and under Tools, nothing was checked.

    My guess is that since I didn't know what to look for when I first installed, but trusted that the default options would be me working, I now understand why it didn't work out of the box.


  • Qt Champions 2016

    well you are not the first. :) (im in the club too)

    The reason for this is that people might have mingw installed and setup and if it just
    installed it, it might mess up the working setup.
    so while not really super friendly, you will only do it once :)



  • Ok that got rid of my problems.

    I would set this as solved if this was my thread.

    Thanks everyone


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.