Jom and CMake



  • Hi i am having trouble using jom with cmake using VS 2008 express edition. I know it is not properly supported but i was wondering if anyone had figured it out.
    The error i get is
    @I:\ws\91-00250\var\PC\build\Win32\Debug>jom
    jom 0.6.2 - empower your cores

    "C:\Program Files\CMake 2.8\bin\cmake.exe" -HI:\ws\91-00250\var\PC\src -BI:\ws\9
    1-00250\var\PC\build\Win32\Debug --check-build-system CMakeFiles\Makefile.cmake
    0
    -- Using FREE VC TOOLS, NO DEBUG available
    -- Using FREE VC TOOLS, NO DEBUG available
    -- Configuring done
    -- Generating done
    -- Build files have been written to: I:/ws/91-00250/var/PC/build/Win32/Debug
    "C:\Program Files\CMake 2.8\bin\cmake.exe" -E cmake_progress_start I:\ws\91-0025
    0\var\PC\build\Win32\Debug\CMakeFiles I:\ws\91-00250\var\PC\build\Win32\Debug\CM
    akeFiles\progress.marks
    I:\bin\jom.exe -f CMakeFiles\Makefile2 /nologo - all
    I:\bin\jom.exe -f lib\91-00250\IBMPC\MSWIN32\CMakeFiles\91-00250.dir\build.make
    /nologo - lib\91-00250\IBMPC\MSWIN32\CMakeFiles\91-00250.dir\depend
    ERROR in line 54: Can't open
    command failed with exit code 2
    QFSFileEngine::open: No file name specified
    command failed with exit code 2@

    the directory lib\91-00250\IBMPC\MSWIN32\CMakeFiles\91-00250.dir\ exists however there is no depend file just depend.make depend.internal etc

    i have tried with both the standard jom and the version found here "http://qt.gitorious.org/~saroengels/qt-labs/jom-cmake/trees/master":http://qt.gitorious.org/~saroengels/qt-labs/jom-cmake/trees/master

    the command i run is
    @ cmake ../../../src -DCMAKE_BUILD_TYPE:STRING=Debug -G "NMake Makefiles JOM"@
    with some additional flags to set internal variables


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.