"QtQuick.Controls.Styles" version 1.4 is not installed



  • Hi,
    everybody.
    this is my first message to this community.

    My problem is the following one :
    In Debian (8.1) i installed by repository qtcreator, then i installed in my /home qt5.6 also.

    when i run the following qml :

    import QtQuick 2.0
    import QtQuick.Controls.Styles 1.4
    import QtQuick.Extras 1.4
    
    Rectangle {
        width: 400
        height: 400
    
        CircularGauge {
            id: gauge
            anchors.fill: parent
            style: CircularGaugeStyle {
                labelInset: outerRadius * 0.2
    
                tickmarkLabel: null
    
                tickmark: Text {
                    text: styleData.value
    
                    Text {
                        anchors.horizontalCenter: parent.horizontalCenter
                        anchors.top: parent.bottom
                        text: styleData.index
                        color: "blue"
                    }
                }
    
                minorTickmark: Text {
                    text: styleData.value
                    font.pixelSize: 8
    
                    Text {
                        anchors.horizontalCenter: parent.horizontalCenter
                        anchors.top: parent.bottom
                        text: styleData.index
                        font.pixelSize: 8
                        color: "blue"
                    }
                }
            }
    
            Text {
                id: indexText
                text: "Major and minor indices"
                anchors.horizontalCenter: parent.horizontalCenter
                anchors.bottom: valueText.top
                color: "blue"
            }
            Text {
                id: valueText
                text: "Major and minor values"
                anchors.horizontalCenter: parent.horizontalCenter
                anchors.bottom: parent.bottom
            }
        }
    }
    

    i get the following error : "QtQuick.Controls.Styles" version 1.4 is not installed

    i'm sure this library is installed inside Qt5.6 path, but maybe i'm not using it due to environment path error configuration (i'm using the repositories libraries).
    Could you help me to configure the environment in order to use the Qt5.6 library ?

    Best regards.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.