Important: Please read the Qt Code of Conduct -

Debugging an application by QtCreator on imx6qsabresd

  • I am using the platform imx6qsabresd with yocto 1.8 and the fsl bsp 3.14.52. I bitbaked the image fsl-image-qt5 and compiled a simple hello_world project in the QtCreator The program is as follows:

    int main(void)
    unsigned int i = 0;
    open("/home/root/qttest.txt", O_CREAT);
    while (1)
    i = i +2;
    if (i > 0xffffff00)
    i = 0;

    And tried to debug it remotely and failed with deployment and also by
    attaching to running process the QtCreator showed the list of processes
    of the mx6qsabresd and tried to connect to the process but did not succeed
    It tried and tried until debugging was aborted.

    The Qi version is 5.5.1 and the version of ubuntu I am working with (on which the QtCreator is installed) is 14.04.1

    I tried also to bitbake the image core-image-sato-sdk with the same results.

    I would be happy if someone could help me with tha issue


Log in to reply