unable to load a route with mapViewer example on QT5.6

  • Re: [SOLVED]load gps map view
    I used an example from QT which is mapviewer in QT 5.6 but it is not working.
    I mean I can't load a route if I enter a fromLatitude , fromLongitude, toLatitude and toLongitude.
    I added logs and I see that the status of my routeModel is not ready but error and exactly undefined error.
    I am working on ubuntu 14.04.
    Do you have same problem than me ?

    If I look on the application output, I can see 2 warnings but I am not sure it is the cause :
    -qt.network.ssl: QSslSocket: cannot resolve SSLv2_client_method
    -qt.network.ssl: QSslSocket: cannot resolve SSLv2_server_method

    Do you think it could be the cause of the error ? If Yes, how to correct it ? Perhaps it is a problem with a proxy ?

    Thank you in advance for your answer.

  • Hi!
    The RouteModel QML type has an error property and an errorString property, see here. What error do they report?

  • Hello,

    both error property and errorString property are undefined.
    That's why I can't figure it out. I don't knew how to resolve a problem as undefined.
    I tried the mapviewer in my personal computer too which is windows 64 bits and I have the same problem.

    Thank you for your answer.

  • Sorry I made a mistake, I can see the error code 2 : host is not accessible.

    An idea to resolve it ?

  • Lifetime Qt Champion


    As silly as it may sound: fix your network ? More seriously, check that the map data provider is online.

  • Hi,

    I resolved it. It was because of a proxy.
    Thank you for your help

  • Lifetime Qt Champion

    Good !

    Since you have it working now, please mark the thread as solved using the "Topic Tool" button so that other forum users may know a solution has been found :)

    You have to first turn this thread into a question (again the Topic Tool button under the first post)

Log in to reply