qt 5.6.0 installation



  • Installation, cygwin1.dll, "no engine"


  • Qt Champions 2016

    Hi and welcome
    You should write more about
    what platform u are installing on and where you downloaded Qt,
    Also when/ how it says "no engine".



  • sorry for the cryptic original post - I misstook the compose box for a tag box.
    I have Windows 7 64 bit, and Visual Studio 2015 Professional. I Installed QT 5.6.0 for VS 2015, first 64 bit, then in a 2nd attempt 32 bit offline. When I try to start Creator, I get this error: "The program can't start because cygwin1.dll is missing from your Computer. Try reinstalling the program to fix this problem." (32 bit Qt, I think it was cygwin3.dll for 64 bit). After 10 or 20 seconds, Creator starts up, anyway. I can edit (text) and compile a very simple application. When I try to debug it by pressing F5, I get the error "Unknown Debugger type "No engine" Unable to create a Debugger engine of type "No engine"". (I can run my application if I copy it into "C:\Qt\Qt5.6.0\5.6\msvc2015\bin", haven't set the path yet.) I also tried the online installer, but it gets stuck at 99% during metadata download for a long time, so far I have been waiting for more than an hour.
    The questions:

    • How do I get rid of the cygwin related error?
    • How can I make the debugger work?
    • If all this has been answered elsewhere: please give me a pointer to the correct articles/questions
      Best
      Otto

  • Qt Champions 2016

    Hi
    Well that explains why it sounded a bit rushed :)

    • How do I get rid of the cygwin related error?
      That is really odd as im on win 7 too and i dont have
      any cygwin*.dll on my system.

    I have no idea why this errors comes. Can your virus scanner have disturbed the installation?


  • Moderators

    That's very strange... there should be no Cygwin dependency. Where did you download Qt from?

    As for the debugger, search for "Debugging Tools for Windows" on Microsoft's site and install that. Qt Creator will auto-detect the debugger.



  • I downloaded from here:
    https://www.qt.io/download-open-source/

    Debugger:
    I installed the Windows SDK, and Creator auto-detects the 64 bit Version of cdb.exe (tools->options->build&run->debugger), but still the "no engine" error Comes up when I press F5 or F10. I tried to manually set up the 32 bit Version, but that makes no difference. Creator says about the auto-detected 64 bit version:
    Type: CDB, ABIs: x86-windows-msvc2013-pe-64bit, Version: Unknown.
    32 bit Version of cdb:
    Type: CDB, ABIs: x86-windows-msvc2013-pe-32bit, Version: 10.0.10586.567


  • Moderators

    @Otto1 said:

    Creator auto-detects the 64 bit Version of cdb.exe (tools->options->build&run->debugger), but still the "no engine" error Comes up when I press F5 or F10.

    Qt Creator detected your debugger, but perhaps it didn't link it with your Kit. Go to Tools -> Options -> Build & Run -> Kits and click on your kit. What does your "Debugger" field say? (It's below the "Environment" field)



  • The field was set to None - switching to the auto-detected CDB worked - thanks!


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.