Important: Please read the Qt Code of Conduct -

Problem with OS X 10.11.4

  • Yesterday I upgraded OS X from 10.11.3 to 10.11.4 and now I'm having issues with the LLDB debugger. I'm using Qt Creator 3.6.1Based on Qt 5.6.0 (Clang 7.0 (Apple), 64 bit) with OS X 10.11.4 and Xcode v 7.2.1 (also tried 7.3).

    Whenever I run a project that uses ui forms the debugger becomes unresponsive when I quit the application and never exits. I have to manually abort the debugger before I can press run again in Qt Creator. I also noticed that if I use any breakpoints now, the debugger also becomes unresponsive. I've narrowed it down to calling "setupUi(this)". If I do not comment out this line all breakpoints work properly and I am able to quit the program and trigger the debugger to stop.
    When setupUi() is called the following error is throw in the debugger log:
    ERROR: Lldb stderr: Exception in thread Thread-1:
    Traceback (most recent call last):
    File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/", line 810, in __bootstrap_inner
    File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/", line 763, in run
    self.__target(*self.__args, **self.__kwargs)
    File "/Users/mark/Qt/Qt", line 769, in loop
    File "/Users/mark/Qt/Qt", line 1409, in handleEvent
    % self.hexencode(msg))
    File "/Users/mark/Qt/Qt", line 479, in hexencode
    return s.encode("hex")
    AttributeError: 'NoneType' object has no attribute 'encode'

    Prior to the upgrade from OS X 10.11.3 everything was working fine. Is this some sort of incompatibility between Apple's newest version of the Python framework and Qt?

    Thanks for the help!

  • Did a similar upgrade yesterday: OSX 10.10 to 10.11.4: everything worked fine. But then I updated the XCode to newest version 7.3 (do not know exactly but former version was 7.2) and now the same effects described above occur!

  • Ah, found the solution: already solved by the QT-guys here on 8th April 2016:

    Had to slightly modify the .../Qt5.6.0/Qt due to the changes of the diff-file, and now everything works fine.

Log in to reply