qt creator crashes on startup, windows 7



  • I have a fresh install from http://www.qt.io/download-open-source/

    When I start up qtcreator.exe, I get "qtcreator.exe has stopped working" and options to "check online.., close the program, debug the program."

    Here are the problem details,

    Problem Event Name: BEX
    Application Name: qtcreator.exe
    Application Version: 0.0.0.0
    Application Timestamp: 566f4a49
    Fault Module Name: StackHash_0a9e
    Fault Module Version: 0.0.0.0
    Fault Module Timestamp: 00000000
    Exception Offset: 00000000
    Exception Code: c0000005
    Exception Data: 00000008
    OS Version: 6.1.7601.2.1.0.256.48
    Locale ID: 1033
    Additional Information 1: 0a9e
    Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
    Additional Information 3: 0a9e
    Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

    Read our privacy statement online:
    http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

    If the online privacy statement is not available, please read our privacy statement offline:
    C:\Windows\system32\en-US\erofflps.txt

    Any ideas how to resolve this? I don't know if it's relevant, but I have the latest version of visual studio express installed. I've also tried some solutions from older threads, e.g. running qtcreator.exe -noload welcome, as well as turning off antivirus software. None of these have worked.



  • Hi, I'm guessing but it looks like you have an antivirus program running, try disabling it.

    EDIT: sorry I didn't read the last line in your post: you said you already tried disabling antivirus software :)
    Hmmm, you could instead try to disable DEP: (this is from googling)

    1. Open your Start menu and click Control Panel
    2. Browse to “System Maintenance” then “System”
    3. In the left panel, select “Advanced System Settings” from the available links
    4. You should now see the System Properties Window, which will have three sections. The top section is labeled “Performance” and has a “Settings” button. Click this button.
    5. Select the “Data Execution Prevention” tab.
    6. Select the option which reads “Turn on DEP for all programs and services except those I select”
    7. Use the “Browse” button to locate qtcreator.exe and click Open to add it to your exceptions list.
    8. Click Apply or OK to commit your changes.


  • Thanks for your reply.

    I've actually tried to disable DEP as well, but it says I can't add qtcreator.exe to the list of exceptions.

    "This program must run with DEP enabled. You cannot turn off DEP for this program."



  • Hmmm, well you could always try the hard way by disabling DEP for all of your Windows 7, start an elevated CMD window:
    bcdedit.exe /set {current} nx AlwaysOff
    Then reboot.

    Note: later, if you want to go back to having DEP enabled:
    bcdedit.exe /set {current} nx AlwaysOn



  • I just came across this too. Still getting the same error. :\



  • son of a ...

    So I went through this page, https://answers.microsoft.com/en-us/windowslive/forum/livemail-program/program-crashes-with-bex-stackhash0a9e/ef6b3f40-7b1b-4e6a-b97a-68d0f26d4277

    and someone resolved this error by uninstalling nvidia's display driver.

    In my case, I finally got qtcreator to boot by uninstalling my amd catalyst driver...



  • Huh! I noticed when I googled that most of the BEX crashes listed were for games. So it could definitively be something in the graphics/video drivers that's causing this.
    Good you got it solved :-)


  • Moderators

    You could try to disable the Welcome plug-in in QtCreator instead of removing your graphics driver.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.