Please nominate your Qt Champions for 2021!

QtMultimedia 5.5 , mp4 playing crashes *** stack smashing detected ***

  • Hello,

    I am trying to figure out why my app crashes with *** stack smashing detected *** when I try to play a mp4 file. avi file do work very well.

    The code is very simple:

    Video {
            id: video
            anchors.rightMargin: 0
            anchors.leftMargin: 0
            anchors.topMargin: 0
            anchors.bottomMargin: 0
            anchors.fill: parent
            source: "file:///home/pilou/OSVR_Projects/testMp4.mp4"
            autoPlay: true

    I am using Ubuntu 15.10 both on a laptop and a desktop , and I come across the same problem twice.

    Checked all my packages etc, all seem OK.

    Can anyone replicate ? Any idea ?

  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Does it happen with all .mp4 files ?

    What version of Qt are you using ?

  • Hello SGaist,

    Thanks for taking the time to reply.

    Tried actually some of the other video examples and every time I have the same issue.
    *** Stack smashing detected ***
    Tried with various mp4s samples from different locations. Same error.
    Also tried with other formats, avi works fine , mkv crashes, mpeg works fine ... hmmm ?
    I can play the movies with VLC and the files are not corrupted. So I would appear to have the adequate codec pack installed.

    Using Qt 5.5.0 gcc 64bit.

  • Lifetime Qt Champion

    Can you run your application through a debugger ?

    That would allow to determine if its within Qt or the GStreamer plugin used.

  • Hello!
    Running the app with valgrind, and seg fault 6.

    ==3317== Process terminating with default action of signal 6 (SIGABRT)
    ==3317== at 0x74A4267: raise (raise.c:55)
    ==3317== by 0x74A5EC9: abort (abort.c:89)
    ==3317== by 0x74E7BF2: __libc_message (libc_fatal.c:175)
    ==3317== by 0x7587E3B: __fortify_fail (fortify_fail.c:38)
    ==3317== by 0x7587DDF: __stack_chk_fail (stack_chk_fail.c:28)
    ==3317== by 0x2E3FE1C1: ??? (in /usr/lib/x86_64-linux-gnu/gstreamer-0.10/
    ==3317== by 0x207414EA: ??? (in /usr/lib/x86_64-linux-gnu/
    ==3317== by 0x21478DFE: gst_pad_set_caps (in /usr/lib/x86_64-linux-gnu/
    ==3317== by 0x2147ABCA: ??? (in /usr/lib/x86_64-linux-gnu/
    ==3317== by 0x2147E627: gst_pad_push (in /usr/lib/x86_64-linux-gnu/
    ==3317== by 0x211DC67F: gst_base_parse_push_frame (in /usr/lib/x86_64-linux-gnu/
    ==3317== by 0x211DDADF: ??? (in /usr/lib/x86_64-linux-gnu/
    ==3317== by 0x2147AB30: ??? (in /usr/lib/x86_64-linux-gnu/
    ==3317== by 0x2147E627: gst_pad_push (in /usr/lib/x86_64-linux-gnu/
    ==3317== by 0x24FEDABF: ??? (in /usr/lib/x86_64-linux-gnu/gstreamer-0.10/
    ==3317== by 0x214A3FB2: ??? (in /usr/lib/x86_64-linux-gnu/
    ==3317== by 0xAE9A2FD: ??? (in /lib/x86_64-linux-gnu/
    ==3317== by 0xAE99964: ??? (in /lib/x86_64-linux-gnu/
    ==3317== by 0x83BE6A9: start_thread (pthread_create.c:333)
    ==3317== by 0x7575E9C: clone (clone.S:109)

    Looks like it is gstreamer related.

  • Lifetime Qt Champion

    Strange, I thought Qt 5.5 was using GStreamer 1 by default

  • I came across the problem of gstreamer version , and it seems that Qt still uses the gstreamer 0.10... despite the port to 1.X being allegedly in the pipeline for a while.
    I had to fiddle around with ppas to get some apps to compile fine with 15.10.
    Still stuck with the same problem.

  • Lifetime Qt Champion

    The port is done, see here

Log in to reply