Qt World Summit: Register Today!

Qt doesn't create me an .exe file !

  • Hello,
    I have just finished a project on Qt. I was initially in debug mode : Qt consequently created a file (I am in shadow build) in which there is a .exe, and where I placed some .dll so it would work. But today, after some modifications, it appeared that the .exe file didn't update : it was an ancient version of the project. So I tried to recompile all the project, it didn't work and then to switch to the release mode : it got worse, because now there is no .exe file created ! I also tried to copy and paste the code to a new project with a different name, and may that be in debug or release, no .exe file is created ! It is a project I have to finish very soon, please help me !

  • @jeff-ekaka

    Some info might help, else there is no way one can know what you're doing.

    • What are you using to build your app? Qt Creator? qmake / make? Visual Studio?

    • Have you tried searching for the executable in case it is being created somewhere else?

    • Posting the compile/link output would help - any errors reported?

  • I have exeperience where makefiles are not getting updated. I would clean everything up and rebuild the project.

  • Finally I have managed to make it work by creating lots of projects, all copy and paste, and finally after 6 or 7 of them one worked correctly... I don't understand. But it worked :) !

Log in to reply