5.4 to 5.5 - XCode C++ breakpoints no longer working



  • Have been using cmake 3.2.1 to generate XCode 6.4 (OSX 10.10) and Visual Studio 2013 (Windows 7) projects, using Qt5.4.1 open source dynamic libraries. The application builds, debugs, and runs fine with Qt5.4.1.

    The Qt libraries were updated to 5.5.1, and it seems that debug breakpoints no longer work in OSX. Breakpoints are still working in Windows builds.

    Nothing else has changed in the project except for the version of Qt. I can switch back and forth between 5.4 and 5.5 and witness the breakpoints stop working with 5.5 every time in XCode.

    I have compared the xcodeproj solution files and there do not seem to be many differences. The only difference that seems like it could be relevant is the addition of a "-fPIC" flag being inserted in OTHER_CFLAGS, but I tried removing those and it made no difference.

    Any ideas on this would be much appreciated.



  • I think this is specific to 5.5.1.

    No one on my team really uses Xcode, but we see the same problem in QtCreator (3.6) with Qt 5.5.1. Using 5.5.0 doesn't present this problem but as soon as we switch over to 5.5.1 breakpoints stop working in QtCreator.

    We've also tried with two separate Qt 5.5.1 builds (that we built ourselves).



  • Interesting that you are seeing similar issues with QtCreator itself.

    Are you linking against the Qt libraries dynamically or statically? Do you see this behavior in only a particular OS?

    I'm not positive, but I suspect that somehow the Mac build configuration is pulling in the release versions of the shared Qt libraries, regardless of which build configuration is selected (Release, Debug, etc).

    I noticed that when the Mac .app is built, the Qt shared library files deployed are the same exact size in Debug and Release versions of the .app, and the library files are very close to the size of the release versions (e.g. QtCore size vs QtCore_debug size). But then I looked at 5.4.1 builds and it looks very similar so that may not be it.

    I agree, this issue seems specific to 5.5.1, in our case 5.5.1 only on a Mac.



  • @salimoneus We are dynamically linking. Our project also builds on Windows and we do not see this problem on there. So far we've seen this problem on OSX 10.9, 10.10 and 10.11.

    What doesn't make sense to me is that it shouldn't matter what builds of Qt are being linked against. Somehow Qt 5.5.1 has broken breakpoints in my own code.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.