Basic apps builds crash as soon as I add a new class...



  • I installed Qt 5.5.1 (Creator 3.6.0) with all the default options.
    The compilator is MinGW 4.9.2 32 bit.
    I have Windows 7 64 bits, and an Intel i5 processor.

    I tried to open an old Qt project of mine, the compilation process is fine, but the build .exe does nothing, there is no error message and I can't even kill the process.

    While investigating I realised it is the same with almost any Qt project, even the built-in exemples ! Only the basic ones with only a single main.cpp (and eventualy resources) work.
    If I just add a new class to these working projects (just basic cpp and h files, no function or attributes at all beside the constructor), again the compilation is fine but the build does not run !

    I tried reinstalling the whole thing, no effect.
    I really have no clue what is happening, if anyone have an idea...



  • Nevermind, it was only Avast Antivirus blocking the builds without any notification...


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.