Using a Qt4 library causes crash on starting of a Qt5 application



  • Hello. I want to use a shared library file. I know its written in Qt4 and has a showcase application which is also written in Qt4. It works fine with Qt4 setup. Then i installed Qt5 and tried to use the library. It crashes while starting (never starts). I double checked the LIBS variable and im sure they are correct. In other case QtCreator cant compile also.

    And then i wanted showcase sources from vendor and thankfully they sent. But the same error occurred. It never started. Application output says <app> crashed. In debug mode disassembler works and shows a line starting with lock incl....

    Unfortunately, There is no way to convert the library to Qt5 as i understand from the vendor.

    What can i do? Any ideas...


  • Qt Champions 2016

    @Hjunior
    Hello,
    If you figure out how to put a square peg into a round hole, do let me know. The problem is that Qt4 and Qt5 are incompatible, you won't ever be able to run it like this, ever. Sorry, but it's just how it is.

    Kind regards.


  • Qt Champions 2016

    well if it will not be ported to Qt5, then u must use Qt4
    https://download.qt.io/archive/qt/4.8/



  • @mrjj Hmm I see but how would we know it man. None of documentation pointed that or may be i didnt see it. Thanks anyway.


  • Qt Champions 2016

    Hi
    Can you tell what would be/is the issue to use 4.8?
    Installation is the same.
    Im not sure what part is unclear.



  • @mrjj Forget it man! Thanks.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.