Videos are not able to play on ubuntu 15.10



  • Hello!
    I have spent a couple of days trying everything to get videos to be able to play on Ubuntu 15.10. Am using qt 5.5 since it supports gstreamer1.0 and i have all of the librarians the that is need to play video on Ubuntu. I have even tried downloading qt 5.6 beta because i read somewhere it was meant to have gstreamer 1.0 as the default instead gstreamer 0.10. Anyone have any solutions to this problem or should i just use windows to develop the application. (Sorry if this hard to read english isn't my first language)

    Warning: "No decoder available for type 'video/x-h264, stream-format=(string)avc, alignment=(string)au, level=(string)3.1, profile=(string)main, codec_data=(buffer)014d401fffe10017674d401fda014016ec0440000003004000000c83c60ca801000468ef3c80, width=(int)1280, height=(int)720, framerate=(fraction)25/1, pixel-aspect-ratio=(fraction)1/1, parsed=(boolean)true'."
    

    This is the error i get


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Did you install gstreamer's various plugin packages ?



  • @SGaist Yes i have all of them, I ran the command sudo apt-get install gstreamer1.0*
    to make sure everything is installed


  • Lifetime Qt Champion

    I don't have a linux machine at hand to verify, can you check that the 5.5.1 gstreamer plugin does link to Gstreamer 1.0 ?



  • @SGaist am not sure how to do that, do you mind explaining how


  • Lifetime Qt Champion

    Call ldd on the plugin. The plugin itself should be in /path/to/Qt/plugins/mediaservice/


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.