Errors running Android Emulator: eglSurfaceAttrib not implemented



  • Hi all,

    I can't get the Android Emulator to work with Qt QML apps at all, even not with the Qt Examples.

    I'm developing on Windows 7, Intel i7, Qt 5.5.1, QtCreator 3.6.0
    I use the most recent versions for Ant, Android NDK and SDK. I use Android x86 with Intel HXVA (but also tried different versions), also I tried different SDK Levels: 19, 21, 22 ... all result in the same errors (here for the QML Caluclator example):

    W/System.err( 2444): java.lang.ClassNotFoundException: android.graphics.drawable.RippleDrawable
    W/System.err( 2444): at java.lang.Class.classForName(Native Method)
    [...]
    W/EGL_emulation( 2444): eglSurfaceAttrib not implemented
    D/OpenGLRenderer( 2444): Enabling debug mode 0
    F/libc ( 2444): Fatal signal 8 (SIGFPE) at 0xb7744ac8 (code=1), thread 2458 (xample.calqlatr)

    The app either crashes or shows a white screen on the emulator.

    I googled a lot for the eglSurfaceAttrib error and there are several posts without any good solution. On the web there are suggestions to disable the "Use Host GPU" setting in the AVD Manager which changes the behavior a little, but doesn't work either.

    Is there any solution for this?

    Any help is more than appreciated!

    Stefan



  • No one? :-(

    Maybe someone who has a working Android Emulator environment on Win 7 can tell me his combination of versions Qt, NDK/SKD and SDK/API level that is working?


  • Lifetime Qt Champion

    Hi,

    You should bring this question on the Android-Development mailing list You'll find the Qt's Android port developers/maintainers (this forum is more user oriented)



  • Did You try GenyMotion as an emulator?
    It is free for personal use and works for me quite well.



  • This issue has been solved in Qt 5.9 Beta 3. Thanks!
    https://bugreports.qt.io/browse/QTBUG-44697


Log in to reply