[solved] QXcbConnection: Could not connect to display [deployment]



  • [my solution is at the end of the message]

    Hi.
    I am encountering the same problem as in this topic :

    QXcbConnection: Could not connect to display 
    Abandon
    

    and I can't manage how to solve it. I read the proposed solution but first apparently, he had troubles when compiling, and he runs it on windows. I couldn't try it as I am working with Linux.

    Here is the situation : I developped an application on Linux/Ubuntu (Ubuntu 14.04.3 LTS) that works fine. I want to deploy it on a server (Debian GNU/Linux 8 ) without installing Qt or compiling it.
    I added all the required libraries into the folder pointed by LD_LIBRARY_PATH. Then I got a problem with xcb wich has been solved by adding the libqxcb to the folder pointed by QT_QPA_PLATFORM_PLUGIN_PATH.

    Since then I have this error and I can't manage how to solve it. I copied all the plugins from from Qtrootdir/plugins/platforms/ to QT_QPA_PLATFORM_PLUGIN_PATH;
    all the qml from Qtrootdir/qml into QML_IMPORT_PATH (and QML2_IMPORT_PATH (as I read this link ) and I can't manage to find anything else to do.

    Would anyone have any idea?
    Thanks :)

    ***Solution : ***
    The problem was that I was trying to display a window when I actually had no monitor or anything.
    So I used ssh -X in order to use my computer's display.

    I hope this will help people in the future.



  • @Maelp said:

    I want to deploy it on a server

    Are you sure your X server is up and running?



  • Hi,

    The problem was that I was trying to display a window when I actually had no monitor or anything.
    So I used ssh -X in order to use my computer's display.

    I hope this will help people in the future.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.