libQtSerialPort Installation Troubles



  • Hello,

    I'm having trouble installing libQtSerialPort on version 4.8, Qt Creator 3.1.1. I'm cross compiling to a Beaglebone Black running Debian.

    I have both Qt and Creator installed, but I'm having trouble getting the qSerialPort plugin installed.

    As far as possible, I've followed the instructions on the wiki.

    I've downloaded the source code, and run qmake on the project file. When I run make on the makefile, it fails notifying me of a LOT of multiple declarations in moc_qserialport.o and moc_qserialport.cpp.

    I don't understand where these are coming from or why I am getting these errors. Any suggestions on how to deal with this are appreciated.


  • Lifetime Qt Champion

    Hi,

    IIRC there's a Qt4 dedicated branch, did you use that one ?



  • Yes I did. I cloned the git repository, checked out the qt4-dev branch, made my qtserialport-build directory, ran qmake ../qtserialport/qtserialport.pro which generated my make file. I ran make and it goes most of the way through until it generates this list of multiple declarations.



  • OK, so I'm not certain what exactly I did, it appears to be something to do with my PATH variable, but I somehow got it to compile and install. A bit of a head scratcher on what I did differently, but it's in now. Thanks anyways for the help!


  • Lifetime Qt Champion

    Well the essential is that you now have it working :)

    Please mark the thread as solved using the "Topic Tool" button so that other forum users may know a solution has been found :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.