Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

cannot open file 'shell32.lib'



  • I just installed Qt. The Terminal Program works, but the GUI Program fires up a error:
    :-1: error: LNK1104: cannot open file 'shell32.lib'

    What can I do to solve this problem?


  • Lifetime Qt Champion

    hi and welcome
    what gui program ?
    If you create a new GUI project. does it run?

    I assume you are on Windows?

    Also are you using mingw compiler or Visual Studio ?



  • Do you have a Chrystal Ball?!!!
    Yes, in all accounts.
    Last question's answer is Visual Studio Community 2013/2015, both are installed.
    I also have Windows Kit installed.
    Thanks for the help


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    What Qt package did you install ? The one for VS2013 or VS2015 ?



  • thanks everyone, the solution was to add this line
    WIN32:LIBS += C:\Program Files (x86)\Windows Kits\10\Lib\10.0.10586.0\um\x64\shell32.lib
    in the .pro file.
    I solved the problem, thanks.


  • Lifetime Qt Champion

    In the absolute, that's not the correct solution, that lib should be found automatically.



  • Yeah, I hear ya!
    However, I am just a user, and a newbie, soooo.... there isn't much I can do ;)
    If there is an engineer interested in the researching this issue, I am willing to help.
    Thanks for the input SGaist.



  • @Papa Hello.
    I also met this problem today.I tried to find my lib from"C:\Program Files (x86)\Windows Kits\10\Lib\10.0.10586.0\um\x64",but I can not find the "shell32.lib".Then I tried to reinstall WDK10.0,but it's useless.I am still looking for a solution.

     ̄へ ̄


Log in to reply