Important: Please read the Qt Code of Conduct -

mouse events on desktop

  • Hey, i wrote an application which runs on an raspberry pi 2 and is connected to an touchscreen. (eGalax Touch , 1024*600 screen resolution)
    Compiling is done completly by the raspberry pi 2 (Native Build Qt on RPI GUIDE)

    I'm using the TSLIB which works also perfect.
    I disable the Mouse Input by setting QT_QPA_EGLFS_DISABLE_INPUT="1"
    and hide the Cursor by QT_QPA_EGLFS_HIDECURSOR="1".

    But when im starting my application and touch on the screen the mouse cursor behind my app is moving arround and is clicking on buttons etc.
    So after closing my QT application my deskstop is full with windows and applications :-(

    Is there a way to disable this?

    The Problem is i had three shortcouts on my desktop to start my app, to reboot the rpi and to shutdown the pi.

    So it happend several times the rpi is rebooting or shutting down by using my app.

    What can i do to stopping this ?

    Best Regards


Log in to reply