Problem with Qjson



  • Hi all!
    I have problem with qjson library(from http://qjson.sourceforge.net). I downloaded sources and builded for symbian(like in instruction here http://qjson.sourceforge.net/get_it/symbian.html) without errors during building. Then I used qjson library for my project, build it(building is OK without errors) on device(sis-file was created normaly). BUT! When I install this file manualy and trying to launch, nothing happens. If I try to run from Qt, installing is ok, but when launching error "General OS-related error" only.
    If I disconnect qjson library, and not use it, installing and launching normaly, all work...
    Help who can!
    Thx in advance

    P.S.
    I use Qt SDK 1.1



  • It may be caused by the certificate. How do you sign it?



  • I use self-signed certificate, but it does not influence in this case, without doubt. Same time ago I used qjson library with SDK 1.0 on my old computer, and everything was ok with the project,the device launched the application correctly(the certificate was also self-signed). Then I started working with new one, clean, without development environment, after installing Qt SDK 1.1 and building qjson library the problem occured=(



  • Could you please check what exact error did you get? This might be a clue to the solution because a list of all native Symbian error are available "here":http://symbian.newlc.com/Symbian-OS-Error-Codes.html



  • Can u advice me, where is I can take code of my error? Building sis-file is ok, in Application output showed:
    @Executable file: 1189975 2011-05-26T23:54:08 C:\QtSDK\Symbian\SDKs\Symbian3Qt473\epoc32\release\armv5\udeb\MyProject.exe
    Starting application...
    Could not start application: General OS-related error
    Finished.@



  • [quote author="Freeuser" date="1306440113"]Can u advice me, where is I can take code of my error? [/quote]

    Could you try to install the sis file manually? After you finish the installation start the application and I guess the error message will be displayed on the screen.

    Btw what device are you using? I just thought that the required Qt dependencies might not present on the device. If so you should wrap "your sis file with smart installer":http://developer.qt.nokia.com/wiki/Nokia_Smart_Installer_for_Symbian



  • This error can be caused by wrong capabilities or by stack size (rare, but possible).



  • I tried install manualy, of course, installation is ok, but when I launch app, nothing happens . No errors, screen not change.

    About wrong capabilities..This project worked nice before, installed and launched well. I didn't change it. Yesterday I tried other projects, which has use qjson, and all are work equally - not launched. I do not understand what is the problem...



  • If it is interesting for anyone, I solved my problem. I used dynamic linking qjson library to the project like
    @
    symbian: LIBS+= -LC:\qjson\lib -lqjson
    @
    But after building qjson project, file qjson.lib is not created.(I can't find it on computer)
    So I just copied this file from my old computer, and replaced linking on static:
    @symbian: LIBS+= -LC:\qjson\lib -lqjson.lib@

    Thanks for all!


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.