QWebview strange behavior



  • Hi, mighty All,

    There are something, I didn't understand.

    I'd posted this problem already on some Russian Qt forums, but got no explanation.

    I tried to use QWebview in Qt 4.8.x, WinXP 32 bit, mkispec win32-msvc2010

    What I've done:

    Just created window, placed the QWebview on it, allowed content editing, typed one string at least 3-4 words,
    and tried to drag and drop some text from Google search page in firefox between these words.
    What I found:

    Qt 4.8.2: Inserted text is highlighted, all words behind inserted cursor(caret) position disappeared,
    if I place mouse cursor to the beginning of inserted text the selection disappeared, and typing space or any letter in this position produces highlighting, from which I can't get rid off. Remark: this is not the selection only blue colored box!?

    Qt 4.8.5: ASSERTION FAILED: isEndOfParagraph(endOfParagraphToMove), found among bugs, but no patch.

    Qt 4.8.6: ASSERTION FAILED: destination.deepEquivalent().anchorNode()->inDocument(), this case patch found, but my src partly is as described in patch, partly different, and there are confusing comments about unnecessary some operators!?

    The question is: are this problem (and others) really solved?
    May be Digia can produce some thing kinda service pack, which includes correction of solved issues?

    And is there any way to solve such problems?

    Is this problem solved in Qt 5.5?

    Radmir


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.