Important: Please read the Qt Code of Conduct -

Qt Creator 2.2 and Tool Chain for WinCE

  • I've just updated to Creator 2.2, and it's now complaining that it can't build my WinCE apps because it doesn't have a tool chain defined. The WinCE versions are compiled from Qt 4.7.2 and have worked with every previous version of Creator. Is there something I've missed in the configuration that causes this failure?


  • Moderators

    Is the tool chain you need to build for WinCE listed in Tools->Options->Tool chains?

    Is the Qt version fully recognized in Tools->Options->Qt4? What is going wrong if it is not (very last line)? Could you please open a bug report about the issue, attaching your QtCore library for WinCE if the Qt version is not recognized?

  • @Tobias:

    The tool chain isn't listed. When I use Creator 2.1 the Tool chain is shown as "Windows CE" but this doesn't appear in the list of available ones in 2.2. And I have no idea how to add it.

    The Qt version is fully recognised as far as I can tell, the last line (Above helpers: None available) says "Qt version 4.7.2, using mkspec wince50domino_sbc-mipsii-msvc2005" which is what I would expect.

    I'll raise a bug report stating that WinCE isn't included in the Tool Chain.


  • Moderators

    Are there MSVC tool chains listed?

    Which ABI does the Qt version give (hover over the Qt version, please)?

  • MSVC is listed under the auto-detected tool chains, but it hasn't detected any CE versions. Not sure if it should have found them.

    It says arm-windows-ce-pe-unknown for the ABI.

  • I have a similar issue with Qt Creator 2.2.1 and an arm-linux Qt build that was previously working fine with Qt Creator 2.0. I've manually added the Qt 4.7.2 embedded build to the Qt versions, as well as manually added the toolchain. However, there doesn't seem to be a way to map the toolchain the the Qt version.

    Edit (add more info):
    In qt creator the abi of the toolchain reports as unknown-linux-generic-elf-unknown, it actually is a armv5tl-montavista-linux-gnueabi ( GCC/G++ 4.2.x )

    Though there is a "toolchain" field in the project build settings, selecting the manually added toolchain path doesn't seem to be an option.

  • Moderators

    digikata: Qt Creator examines your QtCore library and extracts an ABI from that. Any tool chain supporting that ABI is offered in the project settings to build your code with. There is no need to associate anything manually.

    In the upcoming Qt Creator 2.3 (feature freeze was yesterday) you can override the ABI detected from the GCC compiler. Unfortunately that is not possible in Qt Creator 2.2.

    Could you please tell me the output of your gcc's -dumpmachine? Is that armv5tl-montavista-linux-gnueabi? Then I can make sure to detect that properly in QtC 2.3 so you do not have to meddle with the overrides:)

  • Yes the dumpmachine is the armv5tl-montavista-linux-gnueabi.

    My embedded Qt build was not autodetected. Maybe that because it's installed in /opt/qt4.7emb or it's a cross-compile host - can the QtCore lib still be inspected for across architectures?) I've removed and re-added my embedded Qt 4.7.2 build version - it was built with the the toolchain listed above, but still no mapping show up between the 4.7.2 embedded build and the toolchain.

  • Moderators

    Just add your Qt version manually and you should be fine with that.

  • Tobias: Do you know if the changes for 2.3 will help with the CE problem I was having?

  • Moderators

    I do not know yet, but looking into that issue is on my todo list for 2.3.

    I just hope I can get my hands on the wince tool chain for some testing:-)

  • If there's anything I can do to help let me know. I should be able to clear a couple of days between now and the end of July to help if needed.

  • Moderators

    Oh, thanks! I'll remember that:-)

  • [quote author="Tobias Hunger" date="1309415562"]Just add your Qt version manually and you should be fine with that.[/quote]

    I had already added the Qt version manually, but I can't build with that version because when build is selected, Qt creator pops up that the version has no toolchain. I've added the toolchain manually too, but there's nothing allowing me to assign that manually added toolchain for that Qt version. Actually there is a field in the project build options to select a toolchain, but when a toolchain is selected, the entry comes back blank. Is there a workaround that would allow me to build?

  • Moderators

    See my 3rd comment in this thread.

  • @digikata: I haven't found a work around for this. I just keep an old version of Creator kicking around to do my CE builds.

  • Anyone have a solution for this? I'm experiencing the same issue (Windows CE as well).

  • @fonzi337

    I'm working on a fix for it, but it's not my day job so the work is going slowly.

    The current state is that I'm doing changes after a merge request so it might get in soon.

    If you're interested I can point you to the git repository I'm using and you could build a working version from that. Not ideal, but it might get you started...

  • Thanks Steve. Yes, if you could point me to the git repository you're using that would be great. For the time being I'm stuck using command line to build Windows CE apps. :/

  • Any update on this? We just switched to using Qt for our Windows CE 5 development, and I was hoping to be able to use Qt Creator as our IDE for this, instead of Visual Studio.

    But Qt Creator (2.3.1 as well as 2.4 beta) fails to find a tool chain for my Qt 4.7.3, built against our Windows CE 5 SDK using Visual Studio 2005.

  • @ludde

    Sorry for no updates lately... The current situation on my fix for the problem is that I've got a version of creator working with WinCE 5 (and 6) tested with Visual Studio 2005. I spoke to Tobias at Dev Days and had an initial code review which I have just finished the updates for.

    The next step is learning the new Gerrit system to try and get my changes included... I'll try very hard to get this into 2.5.

  • That's great news. If it's possible for you to somehow make a patch available, e.g. by attaching it to your bug report, I'd be happy to try it out.

  • @ludde

    No problem, @fonzi337 has already been trying some of my earlier attempts. I'll put a link to my Gitorious clone up here when I've got the current version working.

    I'll also try and find somewhere to put just the binaries to save you having to compile the whole thing.

  • @ludde

    My latest changes have been merged into the main branch of QtCreator which should mean that it will be included in 2.5. If you're interested you could try compiling your own version of Creator from the master repo.

    Sorry for the delay, but I had real problems trying to get my head around Git / Gerrit etc. so have messed up several times trying to get this in.

  • @Steve, me too facing this similar issue on commercial Qt creator , 2.4.1 , any idea when Commercial ed. 2.5 would be availble ?. Can I take the code and compile for commercial edition as well ? from git..?

    My environment, VS2005, WinCE6.0R3, Qt Creator 2.4.1

    Any help/suggest is appreciated....

  • @steveking, My Qt version is : 4.8.0 if this also helps

Log in to reply