Important: Please read the Qt Code of Conduct -

First Time Install and Build (Loaded project doesn't build)

  • I found a nice project and the following wiki instructions Client Installation .

    I downloaded the git build and installed the latest Qt Creator 3.5.1 and then loaded the project but that's where I'm lost. I was hoping it was as simple as Ctrl+B to build the project but it's grayed out. I can't find in the Qt creator overview how to do something that should normally be simple. It's almost like I'm missing a component of Qt Creator. The install is based on a 3.17-5 towo-siduction kernel 32 bit build. Not sure if the apt-get repository install was missing anything during the install.

    Thanks for any help.

  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Did you install the complete Qt SDK or only Qt Creator ? If the former, you should rather get the online installer and install both Qt and Qt Creator.

  • Thanks I am giving that a try as I'm typing this. I had a compiler installed and was confused when Qt creator mentioned something about needing possible plugins or kits. Qt Creator was over 500 Meg on this slimmed version of Linux now I notice Qt SDK is another 430 Meg or so and watching it install now i'm dumbfounded how there is 96.4 MB of just docs + 44.4 MB of html-docs alone..

    Stay Tuned.....

  • OK that's now all installed and I'm still at the part of having the project loaded and it saying "
    Qt Creator can use the following kits for project Libki:
    No valid kits found.
    The project Libki is not yet configured.
    Qt Creator uses the kit Desktop to parse the project.
    Please add a kit in the options or via the maintenance tool of the SDK.

    Then I click on options which brings up the Build & Run options which shows the KITS tab. There is nothing under Auto-Detected and a Desktop (Default) under Manual but that option has an warning exclamation.

    I am guessing I chose that Manual option. Not sure if I need to fill in anything in the empty fields such as the File System Name. Wouldn't know what to put into that field for the prebuilt project that I imported from the git.

  • Lifetime Qt Champion

    Just to be sure, how did you install Qt ? Using your distribution package manager or Qt's Online Installer ?

  • Using the distributions package manager. Was that a bad idea?

  • Lifetime Qt Champion

    No it's not but that's an important detail.

    Did you install Qt's dev packages ?

  • Oh no I didn't. So far just the 2 packages:

    apt-get install qt-sdk
    apt-get install qtcreator

    just now tried qt5-default (since it's qt5.5 that I installed) still no build option no kit detected)

    Very close now had to
    apt-get install qmlscene
    apt-get install libqt5webkit5-dev

    now have an error edit mode says
    ERROR: Unknown module(s) in QT: script

    How can I find out what module has the error or what I need?

    Found the output window which says:

    Error while building/deploying project Libki (kit: Desktop)
    When executing step "qmake"

    So stuck there now and still not sure if I filled in the Manual Desktop (Default) Kit values correctly. Specifically "File system name" and qtmkspec.

    Thanks again.

  • OK Got it THANKS.

    It takes a little more knowledge about IDE's to build a project. One of the most rudimentary steps is making sure your compiler is working haha. Going through the option tabs
    Don't quote me on which installed packages installed what items. If I get time I will reinstall and give more detail

    1. Compilers Tab: It automatically detected the Compiler after I believe it was "apt-get install build-essentials" which possibly added the compiler
    2. Debuggers Tab: I think that was the qt-sdk.
    3. CMake Tab: Also got that to say automatically detected had to apt-get install cmake and had to point it to the right folder.
    4. Kits Tab; I had to edit the manual Desktop (default) item since I wanted this just to run on this desktop and as far as File System Name field I used the word Test and it seemed to work. Not sure what this does. Maybe someone else can say exactly what that field is for.

    Thanks for all your help!

  • Lifetime Qt Champion

    Build-essentials gets you what's needed to build stuff so basically gcc and g++

    Next time, try installing Qt first and then Qt Creator, that might get you the auto-detection of Qt.

    You're welcome !

    Since you have it working now, please mark the thread as solved using the "Topic Tool" button so other forum users may know a solution has been found :)

    Also, while browsing the forum, please consider up-voting answers that helped you. That will make them easier to find for other users :)

  • Sounds good thanks again. Just going to update my answer a little to help anyone in the future. I actually started from scratch at home and installing Qt through the web first didn't make a difference but I didn't notice the Qt Creator had a link on the same download page so I used apt-get install qtcreator. Will actually try it from scratch one more time later and maybe clean up my solution above.

    Brief setup here:
    apt-get install build-essential
    apt-get install libgl1-mesa-dev
    download Qt and put in good folder from
    chmod +x .run
    #Now run qt installer
    .run #(it installs qmake)
    #I installed it to default /opt/Qt folder
    #I installed Qt 5.5 & Tools & QtExtras
    apt-get install qtcreator #(it installs gcc)
    apt-get install cmake
    apt-get install gdb
    apt-get install qt-sdk (maybe not needed forgot to set kit tab qtversion)
    apt-get install qmlscene
    apt-get install libqt5webkit5-dev

  • Lifetime Qt Champion

    If you installed Qt with the installer then you don't need to install the qt-creator nor qt-sdk packages. build-essentials and libgl1-mesa-dev should be enough.

Log in to reply