Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

QtGUI version incompatible



  • Hello,

    I am compiling a .pro file to use an application of visualization of simulation results (NetAnim).
    This application requires the use of Qt 4.7, However i am on mac SO El CApitain which does not support this version.

    Thu, i installed Qt 4.8
    I make the executable file . But when i launch ./NetANim: i got this error
    dyld: Library not loaded: /usr/local/opt/qt/lib/QtGui.framework/Versions/4/QtGui
    Reason: Incompatible library version: NetAnim requires version 4.8.0 or later, but QtGui provides version 4.7.0
    Trace/BPT trap:

    Any help please?
    Regards


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Did you rebuild your application with Qt 4.8.7 ?