Suppressing xterm in Qt app



  • My Qt app pop up terminal window, when I run it on my Red Hat OS. There is no "CONFIG += console" in my .pro file, I tried to add "CONFIG -= console", but this doesn't help. When I run same project on my Ubuntu system - everything is fine, there is only my application window. Only difference that on Ubuntu I compile my project with qmake and on Red Hat - with qmake4. What seems to be a problem?



  • HI and welcome to devnet,

    this happens only on your project or also for other projects (for instance an example one)?
    Could you post your .pro file?



  • @mcosta for other projects too. Tried http://doc.qt.io/qt-4.8/qt-layouts-basiclayouts-example.html - same thing, xterm window pop up.
    .pro file:

    QT += core gui

    greaterThan(QT_MAJOR_VERSION, 4): QT += widgets

    TARGET = Replication
    TEMPLATE = app

    SOURCES += main.cpp
    mainwindow.cpp
    dialog.cpp

    HEADERS += mainwindow.h
    dialog.h

    FORMS += mainwindow.ui
    dialog.ui

    CONFIG -= console



  • Are you using Qt4 in both cases?

    Running from command line or from Qt Creator?



  • @mcosta On Ubuntu - QMake version 3.0
    Using Qt version 5.2.1 in /usr/lib/x86_64-linux-gnu
    On Red Hat - QMake version: 2.01a
    Using Qt version 4.8.4 in /usr/lib64/qt48/lib64
    Running with executable icon, after I compile project.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.