QtCreator 3.5.1 on Windows 10 hang issues



  • Hi everyone!
    I recently upgraded to Windows 10 x64 (fresh install).

    Before the upgrade, QTCreator 3.5.1 worked flawlessly, but now, most of the time when I right click on a function name in my code for example, the menu comes up after a long 5-10 seconds, and if I click on "Go to declaration", I have to wait another 5-10 seconds for QT to get me there.
    If I just click on the function name and press F2, QtCreator still hangs.
    Also, when copying text, Qt hangs for some seconds.
    It is interesting to note that:

    • I have another PC, same OS, same Qt, same project, and I encounter the same problems
    • The problems do not happen on small projects (I do not encounter these problems with the sample projects provided with Qt)
    • I have tried to recreate the project and then adding my source files, to no avail.

    Thank you very much for any help, I'm this close to downgrading to Windows 8.1!



  • Well I just installed a clean Windows 10 on a virtual machine, and the problem still occurs, meaning the problem does not come from any third party applications.


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Sounds strange, you should take a look at the bug report system to see if it's something known. If not please consider opening a new report providing as much details you can about your setup (Windows 10 version, update applied, graphic card etc.)



  • Hi just out of curiosity, to add to @SGaist 's answer, what compiler are you using? (I'm using MinGW 4.9.2 32bit on my Windows 10 PC and Qt Creator seems happy even with larger projects.)
    If you're on MSVC2013 check that you've applied Update 5.

    BTW, one thing I've seen re. slowness on my Windows 10 PC, is opening Qt projects on a networked drive. Once I copied them down to my C: everything was fine and dandy again.



  • Hi
    I just submitted a bug report.
    I'm using MinGW 4.9.2 32bit like you, and all my projects are on a healthy local disk.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.