Nominate our 2022 Qt Champions!

qtwebkit in 5.3.1 vs current

  • Hi. I am new to qt and trying to solve some problems with a qtwebkit implementation called uwebkit that used qtwebkit 5.3.1.

    Uwebkit allows qtwebkit to be used inside Unity3d. I'm using to develop an automated browser for Macy's.

    Uwebkit currently gives errors on modern sites such as Macy's. Macy's recognizes that the browser has problems and quits when trying to purchase something.

    I cannot determine if it is the uwebkit implementation or qtwebkit that is causing the problems. The problem occurs after putting something in a cart, then going to checkout, and choosing guest checkout. Macys quits with a "Be right back error..." whereas other browsers do not. The problem is not with Unity3d because there are other webkit implementations for unity that work fine. So the problem is with either uwebkit or qtwebkit.

    Question 1: Is there an installable binary of a current qtwebkit browser for mac/windows that uses the latest qtwebkit so I could check and see if the problem exists with qtwebkit or with just uwebkit?

    Question 2: Are there people on the forum who could troubleshoot and fix a problem with someone elses qtwebkit code? The author provided the source "as is".

  • @dansav said:

    Question 1

    Look for fancybrowser in the qtwebkit examples.

  • How do I load that up and make a build, or is there a mac or windows version example already built somewhere.

    I loaded up QT for open source on my mac.
    I opened up in the 5.3 folders.
    Build all

    Project ERROR: Unknown module(s) in QT: webkitwidgets

    17:15:51: Running steps for project fancybrowser...
    17:15:51: Configuration unchanged, skipping qmake step.
    17:15:51: Starting: "/usr/bin/make"
    make: Nothing to be done for `first'.
    17:15:52: The process "/usr/bin/make" exited normally.
    17:15:52: Elapsed time: 00:00.

  • Nevermind tried again and it worked. So 5.3 does have the same problem as uwebkit in that macys gives the same error.

    Next I tried to build the 5.5 fancybrowser.

    and the same thing happens in both.

Log in to reply