not able to view vectors or strings



  • Hi All,
    I've just noticed that "suddenly" qt creator isn't displaying strings and vectors. It's just showing <not accessible>. I'm unsure when this started, but it's recent, formally I could view then no problem.

    I'm using lubuntu 15.04, creator 3.1.1 , Based on Qt 5.4.1 (GCC 4.9.2, 64 bit).
    I have added c11 to my pro file a few days ago, but it's difficult to remove this now.

    Can anyone advise, is there something I might have turned off, or has a bug been introduced lately?

    Thanks


  • Qt Champions 2016

    hi
    try
    Tools -> Options -> Debugger -> GDB tab
    Uncheck the option (Load system GDB pretty printers)

    worked for me.



  • Thanks! That did it. Sorry to ask but how did you work that out? Was there a logic or did you just randomly click on off options? It would never have occurred to me to do this.


  • Qt Champions 2016

    @tony67
    well I found it on google
    as in windows Qt,
    it did show me vector<xx> and in linux it did not.

    So I searched like around and think i got it of Stack Overflow.
    I tried some stuff before so I remember it clearly as it drove me slightly nuts :)

    So all credits to SO person :)

    Also, yes for the text/sound of that option, I would have bet my house it was not that option. :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.