MediaPlayer error on QT5.5 with IOS9



  • Hello all.

    After updating my QT to 5.5 and my IOS to 9, I tried to run my app on my iphone 5s. My app is a simple Podcast App, that plays audios saved on an AWS S3 storage. Everything worked fine before. But now it's not loading the audios. After checking the status of the MediaPlayer, I got the value 8 (QMediaPlayer::InvalidMedia).

    The error only happens on my iphone, when I run it on the desktop, everything works!

    How can I solve this?

    Regards,
    Renato.



  • I tried with a local MP3 file and it works, but my problem is with MP3 from an URL



  • I have the same situation. But a slightly difference is, Qt5.5 works fine in iOS8. After iOS9 upgrade, the remote mp3 file is not valid anymore.

    Is this caused by Apple new policy?ref: https://developer.apple.com/videos/play/wwdc2015-703/



  • Hello, I have the same situation too. Trying to play a .MP4 from URL not working anymore on ios.( OS X is fine ). The issue seems to come from Xcode7. I tried to compile using xcode6 and to install on ios9 and it worked ! I saw a fix coming with 5.5.1. Any idea when it will be released ?



  • Adding in Info.plist:

        <key>NSAppTransportSecurity</key>
             <dict>
                  <key>NSAllowsArbitraryLoads</key><true/>
             </dict>
    

    fixed my issue. ( not 5.5.1 update ).

    SSL behavior is different in iOS9.....


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.