Debugger Issue



  • I have installed and "ran" some of the example apps and a couple of very simple ones of my own on a Nexus 4 and Samsung Note 4. However, I can never get the debugger to break into the app. My setup is

    QtCreator 3.5, Latest android NDK and SDK, (set up on both Windows and Ubuntu 14.04), tried multiple API Levels (15-22).

    I never get a break point to work anywhere that I set a breakpoint. No errors reported, just "Debugging starting" and "Debugging has finished" and nothing in between. Is there a detailed guide somewhere on this? I have yet to find one that said anything more than what I've tried. I have the same results on 2 different android devices and an emulated Nexus 4. I am compiling with a debug build. Everything looks good, it just never breaks into the executable. Is there some gdb server that I have to run on the android device or something? I figured that Qt Creator took care of all that. I have done remote debugging of ARM devices in the past, so I am familiar with it, but not in particular how it works with Qt Creator. Any help is appreciated. I'll be happy to post any logs that you like.

    Thanks!



  • With help of @sharethl in a similar topic it turns out that current Qt Creator will not debug with any Android SDK above 22.6. I was able to successfully build/debug with the SDK at this link (from google of course) LINK to Google Android SDK 22.6.2 for linux . Now I just have to figure out why it can't enter the "window" code. At least it will breakpoint at main and show the stack and locals.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.