Important: Please read the Qt Code of Conduct -

OpenGl not working properly

  • I am compiling Qt for a Windows 7 Ultimate 64bit system with modern ATI graphics-card that supports OpenGL in Hardware.
    thus I configured including the switches "-opengl desktop -graphicssystem opengl"

    As I don't have Headers/Libraries for OpenGL ES 2.0 / EGL I don't need/want/can-use that - I only want OpenGL!

    But - according to the config-files, QT_CONFIG contains "opengl", "opengles2" as well as "egl" -- why is this?
    -- I did NOT specify "-opengl es2", I did "-opengl desktop"!

    with "opengles2" and "egl" being included in QT_CONFIG, QT won't compile due to all sorts of missing declarations and such...

    when I manually remove the "opengles2"/"egl" from QT_CONFIG and recompile everything again afterwards, I got "cannot read from address 0x00000000" exceptions within QtGui4.dll for the majority of the included examples!
    ...and most of the non-crashing others won't work either, displaying an unreadable/corrupted error-message dialog...

    so, how can I instruct configure to not include opengles2/egl in its configuration?

  • again no help from here :-( ...

    to solve this I just must not specify any opengl option for configure, now I only have opengl and no es2/egl - hope this finally works...

Log in to reply