Important: Please read the Qt Code of Conduct -

[Solved] Qt 5.5 MSVC 2013 Precompiled Packages: Which Windows SDK Version was used?

  • Hello.

    As I currently can not build WebEngine with MSVC 2015, I am forced to use a precompiled Package of Qt 5.5 MSVC 2013 x86 for now.
    Whenever I try to run / build my Application, the 'Windows.h' File can not be found. It worked before I installed the MSVC 2015 RTM and the Windows 10 SDK. MSVC 2013 Update 5 is also installed.

    And I installed manually

    • Windows 8.0 SDK
    • Windows 8.1 SDK

    Even adding 'INCLUDEPATH +=' to the Pro File gave me nothing. And yes, I already un-/reinstalled those Packages a couple of times.

    Does anyone know which Windows SDK Version has been used to compile the Qt 5.5 MSVC 2013 x86 / x64 Package?

  • Hi MeerMusik,

    the right SDK should be Visual Studios 2013 for Desktop. I don´t know if the 2015 RTM installation has any impact on a msvc 2013 installation. The Windows.h is part of MSVC 2013 for Desktop, you don´t need a windows sdk for windows.h. Can you check the compiler of you kit in qtcreator is pointing to the msvc 2013 cl.exe?

  • Hi.

    Yes the Compiler is set to: 'C:\Program Files (x86)\Microsoft Visual Studio 12.0\VC\vcvarsall.bat x86' which calls cl.exe 18.00.40629 x86 correctly.

    I know that it normally should not matter. Compiling with Qt under Windows 10 worked fine. Something must have been broken.

    EDIT01: I unticked "Use Jom instead of nmake". The Error when I try to compile is:

    • NMAKE:-1: error: U1077: 'rc' : return code '0x1'
    • NMAKE:-1: error: U1077: '"C:\Program Files (x86)\Microsoft Visual Studio 12.0\VC\BIN\nmake.exe"' : return code '0x2'

    EDIT02: As nmake could not be found (even as it is in that Directory), I started another multi-hour Session to Uninstall all VS2013(2015) and Windows SDK related Stuff. Revo Uninstaller Pro helps me to make sure every uninstall will be clean.

    Will update this post or make a new Reply later.

  • good luck

  • As nmake could not be found

    Nothing in the error message implies that nmake cannot be found. The message says that nmake ran a program called 'rc' (resource compiler) and it failed. I would look at the actual command nmake was trying to execute and any diagnostic messages rc emitted. It is possibly finding the "wrong" rc.exe, or not finding a file it needs etc.

  • @ChrisW67

    In Qt Creator, when I click on the second Line, the 'Red Error Detail Description' said: nmake could not be found. And even when I started a compile Test (openssl from Source with all MSVC2013 Variables set, it says: nmake could not be found).

    So yes, for whatever reason, nmake could not be found :)
    Something was definitely broken: It seems VS 2015 killed some VS2013 Stuff (dozens Registry Entries where defect or pointed to a wrong location). Even some installed SDK Files where not really installed.

    But I currently do a Un-/Reinstall of all the Tools with Revo Uninstaller.
    [Revo found hundreds of leftover Files and Registry Entries after VS 2015 has been 'successfully' uninstalled. Lets see how this turns out]

  • I have reinstalled VS 2013 and VS 2015 again - where possible without the Mobile Tools, Libs, Headers etc.
    It works again.

    There is also a VS2015 Report at the MSDN Forum. VS2015 RTM is full of Bugs.

    Thanks everybody for your time!

Log in to reply