Windows 10 and MSVC 2015 RTM: Known Workaround?



  • EDIT01: Oops. Totally forgot that Topic. Sorry. Now marked as Solved.
    ++++

    Good Morning Ladys and Gents.

    I have the Problem, that the WebEngine does not get build under Windows 10 and MSVC 2015 (x86 and x64).
    A simple Bug Report has been created.

    I have tried to found an Entry in $File, to make it work with MSVC 2015. No Luck yet. [I have looked for something like 'MSC_VER >=1900' or similar.]

    Should anyone know If I can make it compatible somehow and especially what I must Edit: Any Solution is welcome :)

    Qt Version: 5.5.0 from Source and from Git. All Modules (those available on the Win Platform obviously) with all Examples except the WebEngine are build correctly.

    Thanks!
    Have a great weeked.
    Oliver


  • Lifetime Qt Champion

    Hi,

    AFAIK, it will depends partly on when WebEngine itself starts to build with VS2015



  • Hello.

    Yesterday I have tried the following and failed:

    I have changed the Part from Line 1 in File '..\qtwebengine\tools\qmake\mkspecs\features\functions.prf'
    from:

    !win32-msvc2013: !contains(QT_CONFIG, c++11) {
    

    To:

    !win32-msvc2015: !contains(QT_CONFIG, c++11) {
    

    And in Line 17 from:

    linux-g++*|win32-msvc2013|macx-clang: return(true)
    

    To:

    linux-g++*|win32-msvc2013|win32-msvc2015|macx-clang: return(true)
    

    As I am absolutely new to QtWebEngine, I am not sure If this is enough. But after I found an Entry at code.qt.io from Michael BrĂ¼ning called "Print a more descriptive warning when a build is skipped.", I thought I would give it a try.

    The Result is the following Error:

    Using extra options found in c:\qt5src\qtwebengine\src\core\qtwebengine_extras.gypi
    Traceback (most recent call last):
    
    File "C:/qt5src/qtwebengine/tools/buildscripts/gyp_qtwebengine", line 147, in <module> args.extend(['-Goutput_dir='+ os.path.relpath(output_dir, qtwebengine_root)])
    
    File "C:\Python32\lib\ntpath.py", line 528, in relpath % (path_prefix, start_prefix))
    ValueError: path is on drive D:, start on drive c:
    Project ERROR: -- running gyp_qtwebengine failed --
    NMAKE : fatal error U1077: '(' : return code '0x3'
    Stop.
    NMAKE : fatal error U1077: 'cd' : return code '0x2'
    Stop.
    NMAKE : fatal error U1077: 'cd' : return code '0x2'
    Stop.
    

    ['Python32' is Python 32-bit but it contains the latest Python 2.7 Package. Bad old naming leftover.]
    I dont know enough about QtWebEngine and nearly nothing about Python. I have to wait for a fix from someone who knows what (s)he's doing. My Bug Report has set to P2 - so with any luck, this will be fixed in 5.5.1

    Until then I have to work with a pre-built MSVC 2013 Package. My Tool is far from ready to be released. So I still have time to wait for a fix for WebEngine and and a fix for ICU as well.

    Have a sunny weekend everyone :)
    Thanks
    Oliver


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.